Skip to content
Laskyr

Plugins · blockstrap-page-builder-blocks · data as of 2026-11-04

Is BlockStrap Page Builder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.1.64)

As of 2026-11-04. 2 issues are on record for older versions; version 0.1.59 or newer fixes all of them that state a fix.

Latest version
0.1.64
Last updated
2026-11-02
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

BlockStrap Page Builder - Bootstrap Blocks combines Bootstrap's power with the block editor's versatility. — by Stiofan

What to do

  1. Update to the latest version (0.1.64). Anything older than 0.1.59 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get blockstrap-page-builder-blocks --field=version shows what you run; wp plugin update blockstrap-page-builder-blocks updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-94632 · published 2026-10-09

Reflected cross-site scripting (XSS) in BlockStrap Page Builder (0.1.58 and older)

Affected
0.1.58 and older
Fixed in
0.1.59
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Stiofan BlockStrap Page Builder - Bootstrap Blocks blockstrap-page-builder-blocks allows Reflected XSS.This issue affects BlockStrap Page Builder - Bootstrap Blocks: from n/a through 0.1.58.

NVD CVE-2026-94632Patchstack advisory

medium 6.5 CVE-2025-30951 · published 2025-06-06

Stored cross-site scripting (XSS) in BlockStrap Page Builder (0.1.36 and older)

Affected
0.1.36 and older
Fixed in
0.1.37
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Stiofan BlockStrap Page Builder - Bootstrap Blocks blockstrap-page-builder-blocks allows Stored XSS.This issue affects BlockStrap Page Builder - Bootstrap Blocks: from n/a through <= 0.1.36.

NVD CVE-2025-30951Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
BlockStrap Page Builder vulnerability status badge
<a href="https://laskyr.com/plugins/blockstrap-page-builder-blocks"><img src="https://laskyr.com/plugins/blockstrap-page-builder-blocks/badge.svg" alt="BlockStrap Page Builder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit