Skip to content
Laskyr

Plugins · blockspare · data as of 2026-11-04

Is BlockSpare safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.2.1)

As of 2026-11-04. 6 issues are on record for older versions; version 5.0.1 or newer fixes all of them that state a fix.

Latest version
5.2.1
Last updated
2026-11-02
Active installs
10,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Build news, magazine, blog and business sites with 60+ Gutenberg blocks, AI tools, custom Theme Builder, 500+ patterns, and starter templates. — by Blockspare

What to do

  1. Update to the latest version (5.2.1). Anything older than 5.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get blockspare --field=version shows what you run; wp plugin update blockspare updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-1242 · published 2026-09-19

Missing authorization check in BlockSpare (4.2.6 and older)

Affected
4.2.6 and older
Fixed in
5.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by Wordfence
Details from the advisory

The BlockSpare plugin for WordPress is vulnerable to authorization bypass due to incorrect logic in the permission callback in all versions up to, and including, 4.2.6 due to the use of an AND (&&) operator instead of an OR (||) operator. This makes it possible for authenticated attackers, with Subscriber-level access and above, to bypass authorization checks and create arbitrary posts.

NVD CVE-2026-1242Wordfence advisoryPlugin source

medium 4.3 CVE-2025-62026 · published 2025-10-22

Information disclosure in BlockSpare (3.2.13.2 and older)

Affected
3.2.13.2 and older
Fixed in
3.2.14
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in Blockspare Blockspare blockspare allows Retrieve Embedded Sensitive Data.This issue affects Blockspare: from n/a through <= 3.2.13.2.

NVD CVE-2025-62026Patchstack advisory

medium 6.4 CVE-2025-4684 · published 2025-08-01

Stored cross-site scripting (XSS) in BlockSpare (3.2.13.1 and older)

Affected
3.2.13.1 and older
Fixed in
3.3.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The BlockSpare: Gutenberg Blocks & Patterns for Blogs, Magazines, Business Sites – Post Grids, Sliders, Carousels, Counters, Page Builder & Starter Site Imports, No Coding Needed plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the HTML attributes of Image Carousel and Image Slider widgets in all versions up to, and including, 3.2.13.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-4684Wordfence advisoryPlugin source

medium 6.5 CVE-2025-47495 · published 2025-05-07

Stored cross-site scripting (XSS) in BlockSpare (3.2.9 and older)

Affected
3.2.9 and older
Fixed in
3.2.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Blockspare Blockspare blockspare allows Stored XSS.This issue affects Blockspare: from n/a through <= 3.2.9.

NVD CVE-2025-47495Patchstack advisory

medium 6.5 CVE-2024-47363 · published 2024-10-06

Stored cross-site scripting (XSS) in BlockSpare (3.2.4 and older)

Affected
3.2.4 and older
Fixed in
3.2.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Blockspare Blockspare blockspare allows Stored XSS.This issue affects Blockspare: from n/a through <= 3.2.4.

NVD CVE-2024-47363Patchstack advisory

medium 6.5 CVE-2024-43164 · published 2024-08-12

Stored cross-site scripting (XSS) in BlockSpare (3.2.0 and older)

Affected
3.2.0 and older
Fixed in
3.2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Blockspare allows Stored XSS.This issue affects Blockspare: from n/a through 3.2.0.

NVD CVE-2024-43164Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
BlockSpare vulnerability status badge
<a href="https://laskyr.com/plugins/blockspare"><img src="https://laskyr.com/plugins/blockspare/badge.svg" alt="BlockSpare vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit