Skip to content
Laskyr

Plugins · blockons · data as of 2026-11-04

Is Blockons safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.20)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.20 or newer fixes all of them that state a fix.

Latest version
1.2.20
Last updated
2026-10-15
Active installs
700+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Enhanced WordPress editor blocks for Gutenberg, including core Block Extensions and Site Addons for your WordPress site and WooCommerce online store — by Kaira

What to do

  1. Update to the latest version (1.2.20). Anything older than 1.2.20 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get blockons --field=version shows what you run; wp plugin update blockons updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-24550 · published 2026-01-23

Stored cross-site scripting (XSS) in Blockons (1.2.19 and older)

Affected
1.2.19 and older
Fixed in
1.2.20 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Kaira Blockons blockons allows Stored XSS.This issue affects Blockons: from n/a through <= 1.2.19.

NVD CVE-2026-24550Patchstack advisory

high 7.5 CVE-2025-14360 · published 2026-01-08

Missing authorization check in Blockons (1.2.19 and older)

Affected
1.2.19 and older
Fixed in
1.2.20 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Kaira Blockons blockons allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Blockons: from n/a through <= 1.2.19.

NVD CVE-2025-14360Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Blockons vulnerability status badge
<a href="https://laskyr.com/plugins/blockons"><img src="https://laskyr.com/plugins/blockons/badge.svg" alt="Blockons vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit