Plugins · blockonomics-bitcoin-payments · data as of 2026-11-04
Is Bitcoin Payments safe? Known vulnerabilities and latest version
- Latest version
- 3.11.0
- Last updated
- 2026-09-09
- Active installs
- 2,000+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 7.0.8 · PHP 7.4+
Accept Bitcoin/USDT payments on your WooCommerce website. Crypto payments go directly to your wallet. — by blockonomics
What to do
- There is no fixed version yet. If you can live without Bitcoin Payments for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get blockonomics-bitcoin-payments --field=version shows what you run; wp plugin update blockonomics-bitcoin-payments updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 affects latest 3.11.0 CVE-2026-61993 · published 2026-10-29
Cross-site scripting (XSS) in Bitcoin Payments (3.11.0 only)
- Affected
- 3.11.0 only
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Blockonomics 3.11.0 versions.
medium 6.1 CVE-2022-47145 · published 2023-03-23
Reflected cross-site scripting (XSS) in Bitcoin Payments (3.5.7 and older)
- Affected
- 3.5.7 and older
- Fixed in
- 3.5.8
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Reflected Cross-Site Scripting (XSS) vulnerability in Blockonomics WordPress Bitcoin Payments – Blockonomics plugin <= 3.5.7 versions.
Recent activity
- 2026-09-09 — latest release on wordpress.org (3.11.0).
- 2026-10-29 — Cross-site scripting (XSS) disclosed (CVE-2026-61993), no fix listed yet.
- 2023-03-23 — Reflected cross-site scripting (XSS) disclosed (CVE-2022-47145), fixed in 3.5.8.
Get an email when Bitcoin Payments has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Bitcoin Payments (blockonomics-bitcoin-payments) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/blockonomics-bitcoin-payments (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/blockonomics-bitcoin-payments"><img src="https://laskyr.com/plugins/blockonomics-bitcoin-payments/badge.svg" alt="Bitcoin Payments vulnerability status"></a>