Skip to content
Laskyr

Plugins · blockart-blocks · data as of 2026-11-04

Is BlockArt Blocks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.2)

As of 2026-11-04. 4 issues are on record for older versions; version 2.3.0 or newer fixes all of them that state a fix.

Latest version
2.4.2
Last updated
2026-10-15
Active installs
10,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Enhance the power of your WordPress editor with the dynamic Gutenberg blocks by BlockArt Blocks. Build any layout imaginable. — by BlockArt

What to do

  1. Update to the latest version (2.4.2). Anything older than 2.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get blockart-blocks --field=version shows what you run; wp plugin update blockart-blocks updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-3498 · published 2026-04-11

Stored cross-site scripting (XSS) in BlockArt Blocks (2.2.15 and older)

Affected
2.2.15 and older
Fixed in
2.3.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The BlockArt Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'clientId' block attribute in all versions up to, and including, 2.2.15. This is due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-3498Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2025-14283 · published 2026-01-28

Stored cross-site scripting (XSS) in BlockArt Blocks (2.2.14 and older)

Affected
2.2.14 and older
Fixed in
2.2.15 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The BlockArt Blocks – Gutenberg Blocks, Page Builder Blocks ,WordPress Block Plugin, Sections & Template Library plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the BlockArt Counter in all versions up to, and including, 2.2.14 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-14283Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2025-13697 · published 2025-12-02

Stored cross-site scripting (XSS) in BlockArt Blocks (2.2.13 and older)

Affected
2.2.13 and older
Fixed in
2.2.14 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The BlockArt Blocks – Gutenberg Blocks, Page Builder Blocks ,WordPress Block Plugin, Sections & Template Library plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘timestamp’ attribute in all versions up to, and including, 2.2.13 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-13697Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-35704 · published 2024-06-08

Stored cross-site scripting (XSS) in BlockArt Blocks (2.1.5 and older)

Affected
2.1.5 and older
Fixed in
2.1.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in WPBlockArt BlockArt Blocks allows Stored XSS.This issue affects BlockArt Blocks: from n/a through 2.1.5.

NVD CVE-2024-35704Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
BlockArt Blocks vulnerability status badge
<a href="https://laskyr.com/plugins/blockart-blocks"><img src="https://laskyr.com/plugins/blockart-blocks/badge.svg" alt="BlockArt Blocks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit