Skip to content
Laskyr

Plugins · block-for-mailchimp · data as of 2026-11-04

Is Block for Mailchimp safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.17)

As of 2026-11-04. 2 issues are on record for older versions; version 1.1.16 or newer fixes all of them that state a fix.

Latest version
1.1.17
Last updated
2026-10-30
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Add Mailchimp email subscription forms to WordPress with a Gutenberg block – inline, popup, or floating layouts. Grow your newsletter list fast. — by bPlugins

What to do

  1. Update to the latest version (1.1.17). Anything older than 1.1.16 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get block-for-mailchimp --field=version shows what you run; wp plugin update block-for-mailchimp updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.3 CVE-2026-56063 · published 2026-06-26

Missing authorization check in Block for Mailchimp (1.1.15 and older)

Affected
1.1.15 and older
Fixed in
1.1.16
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in MailChimp Block <= 1.1.15 versions.

NVD CVE-2026-56063Patchstack advisory

medium 4.0 CVE-2025-10735 · published 2025-10-01

Server-side request forgery (SSRF) in Block for Mailchimp (1.1.12 and older)

Affected
1.1.12 and older
Fixed in
1.1.13 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Block For Mailchimp – Easy Mailchimp Form Integration plugin for WordPress is vulnerable to Blind Server-Side Request Forgery in all versions up to, and including, 1.1.12 via the mcbSubmit_Form_Data(). This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

NVD CVE-2025-10735Wordfence advisoryCode change (fix)wordpress.orgplugins.svn.wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Block for Mailchimp vulnerability status badge
<a href="https://laskyr.com/plugins/block-for-mailchimp"><img src="https://laskyr.com/plugins/block-for-mailchimp/badge.svg" alt="Block for Mailchimp vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit