Plugins · blackhole-bad-bots · data as of 2026-11-04
Is Blackhole for Bad Bots safe? Known vulnerabilities and latest version
- Latest version
- 3.8.4
- Last updated
- 2026-08-21
- Active installs
- 30,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6.20+
Blackhole is a WordPress security plugin that detects and traps bad bots in a virtual black hole, where they are denied access to your entire site. — by Jeff Starr
What to do
- Update to the latest version (3.8.4). Anything older than 3.8.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get blackhole-bad-bots --field=version shows what you run; wp plugin update blackhole-bad-bots updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-4329 · published 2026-03-26
Stored cross-site scripting (XSS) in Blackhole for Bad Bots (3.8 and older)
- Affected
- 3.8 and older
- Fixed in
- 3.8.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Blackhole for Bad Bots plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the User-Agent HTTP header in all versions up to and including 3.8. This is due to insufficient input sanitization and output escaping. The plugin uses sanitize_text_field() when capturing bot data (which strips HTML tags but does not escape HTML entities like double quotes), then stores the data via update_option(). When an administrator views the Bad Bots log page, the stored data is output directly into HTML input value attributes (lines 75-83) without esc_attr() and into HTML span content without esc_html(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute when an administrator views the Blackhole Bad Bots admin page.
NVD CVE-2026-4329Wordfence advisoryCode change (fix)Plugin source
critical 9.1 CVE-2022-1165 · published 2022-04-04
Missing authorization check in Blackhole for Bad Bots (older than 3.3.2)
- Affected
- older than 3.3.2
- Fixed in
- 3.3.2
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by NVD
Details from the advisory
The Blackhole for Bad Bots WordPress plugin before 3.3.2 uses headers such as CF-CONNECTING-IP, CLIENT-IP etc to determine the IP address of requests hitting the blackhole URL, which allows them to be spoofed. This could result in blocking arbitrary IP addresses, such as legitimate/good search engine crawlers / bots. This could also be abused by competitors to cause damage related to visibility in search engines, can be used to bypass arbitrary blocks caused by this plugin, block any visitor or even the administrator and even more.
Recent activity
- 2026-08-21 — latest release on wordpress.org (3.8.4).
- 2026-03-26 — Stored cross-site scripting (XSS) disclosed (CVE-2026-4329), fixed in 3.8.1.
- 2022-04-04 — Missing authorization check disclosed (CVE-2022-1165), fixed in 3.3.2.
Get an email when Blackhole for Bad Bots has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Blackhole for Bad Bots (blackhole-bad-bots) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Jeff Starr (7 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/blackhole-bad-bots (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/blackhole-bad-bots"><img src="https://laskyr.com/plugins/blackhole-bad-bots/badge.svg" alt="Blackhole for Bad Bots vulnerability status"></a>