Skip to content
Laskyr

Plugins · bitfire · data as of 2026-11-04

Is BitFire Security safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.2.4)

As of 2026-11-04. 2 issues are on record for older versions; version 5.0.4 or newer fixes all of them that state a fix.

Latest version
5.2.4
Last updated
2026-09-24
Active installs
300+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Free WordPress firewall, bot blocking, login protection, and malware scanning. See suspicious traffic and investigate threats from your dashboard. — by Cory Marsh

What to do

  1. Update to the latest version (5.2.4). Anything older than 5.0.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bitfire --field=version shows what you run; wp plugin update bitfire updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.6 CVE-2026-56035 · published 2026-06-26

Security issue in BitFire Security (5.0.3 and older)

Affected
5.0.3 and older
Fixed in
5.0.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Multiple Vulnerabilities in BitFire Security <= 5.0.3 versions.

NVD CVE-2026-56035Patchstack advisory

medium 5.3 CVE-2025-6722 · published 2025-08-02

Information disclosure in BitFire Security (4.5 and older)

Affected
4.5 and older
Fixed in
4.6.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The BitFire Security – Firewall, WAF, Bot/Spam Blocker, Login Security plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.5 via the bitfire_* directory that automatically gets created and stores potentially sensitive files without any access restrictions. This makes it possible for unauthenticated attackers to extract sensitive data from various files like config.ini, debug.log, and more when directory listing is enabled on the server and the ~/wp-content/plugins/index.php file is missing or ignored.

NVD CVE-2025-6722Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
BitFire Security vulnerability status badge
<a href="https://laskyr.com/plugins/bitfire"><img src="https://laskyr.com/plugins/bitfire/badge.svg" alt="BitFire Security vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit