Skip to content
Laskyr

Plugins · bit-pi · data as of 2026-11-04

Is Bit Flows safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.33.0)

As of 2026-11-04. 1 issue is on record for older versions; version 1.32.0 or newer fixes all of them that state a fix.

Latest version
1.33.0
Last updated
2026-11-02
Active installs
1,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

Advanced WordPress automation plugin to connect forms, CRM, eCommerce, LMS, Google Sheets, Mailchimp, ChatGPT and 320+ platforms. — by Bit Apps

What to do

  1. Update to the latest version (1.33.0). Anything older than 1.32.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bit-pi --field=version shows what you run; wp plugin update bit-pi updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2026-110185 · published 2026-10-28

File inclusion in Bit Flows (1.31.0 and older)

Affected
1.31.0 and older
Fixed in
1.32.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Bit Flows: AI Agent Automation & Integrations for Forms, CRM, eCommerce, Google Sheets, and More plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.31.0 via the 'image (any body field referenced by the ImageHelper node's mix tag)' parameter parameter. This makes it possible for unauthenticated attackers to include and execute arbitrary .php files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where .php file types can be uploaded and included. Exploitation requires that an administrator has built a webhook-triggered flow that pipes a webhook body field into an ImageHelper imageToBase64 node, and that the webhook remains in its default configuration (no bearer secret enforced, no IP allowlist set) — a legitimate and documented use case.

NVD CVE-2026-110185Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Bit Flows vulnerability status badge
<a href="https://laskyr.com/plugins/bit-pi"><img src="https://laskyr.com/plugins/bit-pi/badge.svg" alt="Bit Flows vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit