Skip to content
Laskyr

Plugins · bit-integrations · data as of 2026-11-04

Is Bit integrations safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.10.9)

As of 2026-11-04. 5 issues are on record for older versions; version 2.10.7 or newer fixes all of them that state a fix.

Latest version
2.10.9
Last updated
2026-10-26
Active installs
20,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Contact Form, Google Sheet, MailChimp, Brevo, Webhook, Zoho CRM Automation and Integration plugin that Connect 320+ platforms — by Bit Apps

What to do

  1. Update to the latest version (2.10.9). Anything older than 2.10.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bit-integrations --field=version shows what you run; wp plugin update bit-integrations updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-104749 · published 2026-10-14

Privilege escalation in Bit integrations (2.10.6 and older)

Affected
2.10.6 and older
Fixed in
2.10.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Bit integrations – Form Integration, Webhook, Spreadsheets, CRM, LMS & Email Automation plugin for WordPress is vulnerable to Privilege Escalation via Log Re-execution in all versions up to, and including, 2.10.6 The vulnerability exists because `IntegrationHandler::executeWithCapture()` stores raw, attacker-controlled field values — including `user_pass` and `user_email` — verbatim into `wp_btcbi_log.field_data` on anonymous front-end requests with no capability check, and `LogHandler::reexecute()` feeds that stored payload back through `Flow::execute()` inside the replaying administrator's session without validating the identity that originally produced the data, causing `RegistrationController::updateUser()` to resolve the target user ID to the administrator and write the attacker-supplied password via `wp_update_user()`. This makes it possible for unauthenticated attackers to overwrite the administrator's password and fully take over the administrator account. Exploitation requires that an administrator has configured a flow mapping a user-supplied form field to the `user_pass` parameter of the WP User Registration "Update User" action, and that the administrator subsequently clicks "Re-execute" on the failure log row produced by the anonymous submission from the plugin's log screen.

NVD CVE-2026-104749Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2026-102007 · published 2026-10-13

Stored cross-site scripting (XSS) in Bit integrations (2.10.6 and older)

Affected
2.10.6 and older
Fixed in
2.10.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Bit integrations – Form Integration, Webhook, Spreadsheets, CRM, LMS & Email Automation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'field mapped to notification_content (attacker-chosen key, e.g. payload_text)' parameter in all versions up to, and including, 2.10.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires a site administrator to have preconfigured a Bit Integrations flow that binds the public Bit Assist webhook to a BuddyBoss "Send Notification" action with a form field mapped to notification_content, and the attacker to know the flow's UUID callback URL.

NVD CVE-2026-102007Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2026-15006 · published 2026-08-01

Path traversal / file read in Bit integrations (2.9.0 and older)

Affected
2.9.0 and older
Fixed in
2.9.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Bit integrations – Form Integration, Webhook, Spreadsheets, CRM, LMS & Email Automation plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 2.9.0 via the processAttachment function. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information.

NVD CVE-2026-15006Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-11989 · published 2026-06-19

Server-side request forgery (SSRF) in Bit integrations (2.8.7 and older)

Affected
2.8.7 and older
Fixed in
2.8.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Bit integrations – Form Integration, Webhook, Spreadsheets, CRM, LMS & Email Automation plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.8.7 via the upload_attachment. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services. Exploitation requires a form integration to be configured with a field mapped to a WooCommerce product image, product gallery, downloadable files, or Google Contacts attachment field, which is a default use case for these integrations.

NVD CVE-2026-11989Wordfence advisoryCode change (fix)Plugin source

medium 4.7 CVE-2025-30884 · published 2025-03-27

Open redirect in Bit integrations (2.4.10 and older)

Affected
2.4.10 and older
Fixed in
2.5.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Bit Apps Bit Integrations bit-integrations allows Phishing.This issue affects Bit Integrations: from n/a through <= 2.4.10.

NVD CVE-2025-30884Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Bit integrations vulnerability status badge
<a href="https://laskyr.com/plugins/bit-integrations"><img src="https://laskyr.com/plugins/bit-integrations/badge.svg" alt="Bit integrations vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit