Plugins · bit-assist · data as of 2026-11-04
Is Chat Widget safe? Known vulnerabilities and latest version
- Latest version
- 1.8.3
- Last updated
- 2026-07-29
- Active installs
- 9,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Floating sticky chat button for WhatsApp Chat, Facebook Messenger, Telegram, Instagram, SMS, Call, Discord chat, TikTok, Line & 30+ channels — by Bit Apps
What to do
- Update to the latest version (1.8.3). Anything older than 1.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get bit-assist --field=version shows what you run; wp plugin update bit-assist updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-68596 · published 2025-12-24
Missing authorization check in Chat Widget (1.5.11 and older)
- Affected
- 1.5.11 and older
- Fixed in
- 1.6.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Bit Apps Bit Assist bit-assist allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Bit Assist: from n/a through <= 1.5.11.
high 7.5 CVE-2025-30834 · published 2025-04-01
Path traversal / file read in Chat Widget (1.5.4 and older)
- Affected
- 1.5.4 and older
- Fixed in
- 1.5.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Path Traversal: '.../...//' vulnerability in Bit Apps Bit Assist bit-assist allows Path Traversal.This issue affects Bit Assist: from n/a through <= 1.5.4.
medium 6.5 CVE-2025-0822 · published 2025-02-15
Path traversal / file read in Chat Widget (1.5.2 and older)
- Affected
- 1.5.2 and older
- Fixed in
- 1.5.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
Bit Assist plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.5.2 via the fileID Parameter. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
NVD CVE-2025-0822Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 6.5 CVE-2025-0821 · published 2025-02-14
SQL injection in Chat Widget (1.5.2 and older)
- Affected
- 1.5.2 and older
- Fixed in
- 1.5.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Bit Assist plugin for WordPress is vulnerable to time-based SQL Injection via the ‘id’ parameter in all versions up to, and including, 1.5.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2025-0821Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 4.9 CVE-2024-13791 · published 2025-02-14
Path traversal / file read in Chat Widget (1.5.2 and older)
- Affected
- 1.5.2 and older
- Fixed in
- 1.5.3 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
Bit Assist plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.5.2 via the downloadResponseFile() function. This makes it possible for authenticated attackers, with Administrator-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
NVD CVE-2024-13791Wordfence advisoryCode change (fix)wordpress.orggithub.com
medium 4.8 CVE-2023-51371 · published 2023-12-29
Stored cross-site scripting (XSS) in Chat Widget (1.1.9 and older)
- Affected
- 1.1.9 and older
- Fixed in
- 1.2
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Bit Assist Chat Widget: WhatsApp Chat, Facebook Messenger Chat, Telegram Chat Bubble, Line Messenger, Live Chat Support Chat Button, WeChat, SMS, Call Button, Customer Support Button with floating Chat Widget allows Stored XSS.This issue affects Chat Widget: WhatsApp Chat, Facebook Messenger Chat, Telegram Chat Bubble, Line Messenger, Live Chat Support Chat Button, WeChat, SMS, Call Button, Customer Support Button with floating Chat Widget: from n/a through 1.1.9.
Recent activity
- 2026-07-29 — latest release on wordpress.org (1.8.3).
- 2025-12-24 — Missing authorization check disclosed (CVE-2025-68596), fixed in 1.6.0.
- 2025-04-01 — Path traversal / file read disclosed (CVE-2025-30834), fixed in 1.5.5.
- 2025-02-15 — Path traversal / file read disclosed (CVE-2025-0822), fixed in 1.5.3.
Get an email when Chat Widget has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Chat Widget (bit-assist) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Bit Apps (6 tracked)
Types found in this plugin: Path traversal and file read (3) · Missing authorization (1) · SQL injection (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/bit-assist (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/bit-assist"><img src="https://laskyr.com/plugins/bit-assist/badge.svg" alt="Chat Widget vulnerability status"></a>