Skip to content
Laskyr

Plugins · bfg-tools-extension-zipper · data as of 2026-11-04

Is BFG Tools safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.8)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.8 or newer fixes all of them that state a fix.

Latest version
1.0.8
Last updated
2025-12-06
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

A clean, reliable way to package any installed plugin into a ZIP file directly inside WP-Admin. — by Joby Franczek

What to do

  1. Update to the latest version (1.0.8). Anything older than 1.0.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bfg-tools-extension-zipper --field=version shows what you run; wp plugin update bfg-tools-extension-zipper updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2025-13681 · published 2026-02-14

Path traversal / file read in BFG Tools (1.0.7 and older)

Affected
1.0.7 and older
Fixed in
1.0.8 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The BFG Tools – Extension Zipper plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.0.7. This is due to insufficient input validation on the user-supplied `first_file` parameter in the `zip()` function. This makes it possible for authenticated attackers, with Administrator-level access and above, to read the contents of arbitrary files and directories outside the intended `/wp-content/plugins/` directory, which can contain sensitive information such as wp-config.php.

NVD CVE-2025-13681Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
BFG Tools vulnerability status badge
<a href="https://laskyr.com/plugins/bfg-tools-extension-zipper"><img src="https://laskyr.com/plugins/bfg-tools-extension-zipper/badge.svg" alt="BFG Tools vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit