Skip to content
Laskyr

Plugins · betterlinks · data as of 2026-11-04

Is BetterLinks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.6)

As of 2026-11-04. 4 issues are on record for older versions; version 3.1.1 or newer fixes all of them that state a fix.

Latest version
3.1.6
Last updated
2026-11-01
Active installs
20,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Shorten, cloak, redirect & track every link in WordPress. Branded short URLs, click analytics, affiliate links & MCP access for AI assistants. — by WPDeveloper

What to do

  1. Update to the latest version (3.1.6). Anything older than 3.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get betterlinks --field=version shows what you run; wp plugin update betterlinks updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-19801 · published 2026-08-25

Missing authorization check in BetterLinks (3.1.0 and older)

Affected
3.1.0 and older
Fixed in
3.1.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The BetterLinks – Link Shortener, Link Cloaking, Redirects, Affiliate Link Manager & MCP plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.1.0. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to create arbitrary BetterLinks short URLs with attacker-controlled slugs and redirect destinations, enabling phishing and SEO abuse. Exploitation requires the Fluent Boards companion plugin to be installed and active (so that the FLUENT_BOARDS constant is defined), and is further facilitated by the betterlinks_admin_nonce nonce being emitted on every frontend page via wp_localize_script, making it accessible to any authenticated user.

NVD CVE-2026-19801Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2023-45104 · published 2025-01-02

Missing authorization check in BetterLinks (1.6.0 and older)

Affected
1.6.0 and older
Fixed in
1.6.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in WPDeveloper BetterLinks betterlinks allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects BetterLinks: from n/a through <= 1.6.0.

NVD CVE-2023-45104Patchstack advisory

high 7.2 CVE-2024-51672 · published 2024-11-04

SQL injection in BetterLinks (2.1.7 and older)

Affected
2.1.7 and older
Fixed in
2.1.8
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in WPDeveloper BetterLinks betterlinks allows SQL Injection.This issue affects BetterLinks: from n/a through <= 2.1.7.

NVD CVE-2024-51672Patchstack advisory

medium 5.4 CVE-2021-24812 · published 2021-11-23

Stored cross-site scripting (XSS) in BetterLinks (older than 1.2.6)

Affected
older than 1.2.6
Fixed in
1.2.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The BetterLinks WordPress plugin before 1.2.6 does not sanitise and escape some of imported link fields, which could lead to Stored Cross-Site Scripting issues when an admin import a malicious CSV.

NVD CVE-2021-24812WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
BetterLinks vulnerability status badge
<a href="https://laskyr.com/plugins/betterlinks"><img src="https://laskyr.com/plugins/betterlinks/badge.svg" alt="BetterLinks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit