Plugins · better-wp-security · data as of 2026-11-01
Is Kadence Security safe? Known vulnerabilities and latest version
- Latest version
- 10.0.6
- Last updated
- 2026-10-14
- Active installs
- 700,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Harden your site security with Login Security, Two-Factor Authentication (2FA), Vulnerability Scanner, Firewall, and more. Formerly iThemes Security. — by Nexcess
What to do
- Update to the latest version (10.0.6). Anything older than 9.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get better-wp-security --field=version shows what you run; wp plugin update better-wp-security updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2022-44593 · published 2024-06-21
Denial of service in Kadence Security (9.3.1 and older)
- Affected
- 9.3.1 and older
- Fixed in
- 9.3.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Use of Less Trusted Source vulnerability in SolidWP Solid Security allows HTTP DoS.This issue affects Solid Security: from n/a through 9.3.1.
medium 6.1 CVE-2023-28786 · published 2023-12-29
Open redirect in Kadence Security (8.1.4 and older)
- Affected
- 8.1.4 and older
- Fixed in
- 8.1.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in SolidWP Solid Security – Password, Two Factor Authentication, and Brute Force Protection.This issue affects Solid Security – Password, Two Factor Authentication, and Brute Force Protection: from n/a through 8.1.4.
high 7.5 CVE-2020-36176 · published 2021-01-06
Authentication bypass in Kadence Security (older than 7.7.0)
- Affected
- older than 7.7.0
- Fixed in
- 7.7.0
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by NVD
Details from the advisory
The iThemes Security (formerly Better WP Security) plugin before 7.7.0 for WordPress does not enforce a new-password requirement for an existing account until the second login occurs.
high 7.2 CVE-2018-12636 · published 2018-06-22
SQL injection in Kadence Security (older than 7.0.3)
- Affected
- older than 7.0.3
- Fixed in
- 7.0.3
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- advisory text · score by NVD
Details from the advisory
The iThemes Security (better-wp-security) plugin before 7.0.3 for WordPress allows SQL Injection (by attackers with Admin privileges) via the logs page.
NVD CVE-2018-12636wordpress.orglists.apache.orgexploit-db.com
high 7.5 CVE-2018-7433 · published 2018-03-02
Information disclosure in Kadence Security (older than 6.9.1)
- Affected
- older than 6.9.1
- Fixed in
- 6.9.1
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by NVD
Details from the advisory
The iThemes Security plugin before 6.9.1 for WordPress does not properly perform data escaping for the logs page.
Recent activity
- 2026-10-14 — latest release on wordpress.org (10.0.6).
- 2024-06-21 — Denial of service disclosed (CVE-2022-44593), fixed in 9.3.2.
- 2023-12-29 — Open redirect disclosed (CVE-2023-28786), fixed in 8.1.5.
- 2021-01-06 — Authentication bypass disclosed (CVE-2020-36176), fixed in 7.7.0.
Get an email when Kadence Security has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Kadence Security (better-wp-security) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/better-wp-security (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/better-wp-security"><img src="https://laskyr.com/plugins/better-wp-security/badge.svg" alt="Kadence Security vulnerability status"></a>