Skip to content
Laskyr

Plugins · better-search-replace · data as of 2026-11-01

Is Better Search Replace safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.11)

As of 2026-11-01. 2 issues are on record for older versions; version 1.4.5 or newer fixes all of them that state a fix.

Latest version
1.4.11
Last updated
2026-08-25
Active installs
1+ million
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

A simple plugin to update URLs or other text in a database. — by WP Engine

What to do

  1. Update to the latest version (1.4.11). Anything older than 1.4.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get better-search-replace --field=version shows what you run; wp plugin update better-search-replace updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2023-6933 · published 2024-02-05

PHP object injection in Better Search Replace (1.4.4 and older)

Affected
1.4.4 and older
Fixed in
1.4.5 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Better Search Replace plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.4.4 via deserialization of untrusted input. This makes it possible for unauthenticated attackers to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

NVD CVE-2023-6933Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2022-2593 · published 2022-08-22

SQL injection in Better Search Replace (older than 1.4.1)

Affected
older than 1.4.1
Fixed in
1.4.1
Access needed (per CVSS)
Needs an admin-level account
Range from
NVD analysis · score by NVD
Details from the advisory

The Better Search Replace WordPress plugin before 1.4.1 does not properly sanitise and escape table data before inserting it into a SQL query, which could allow high privilege users to perform SQL Injection attacks

NVD CVE-2022-2593WPScan advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Better Search Replace vulnerability status badge
<a href="https://laskyr.com/plugins/better-search-replace"><img src="https://laskyr.com/plugins/better-search-replace/badge.svg" alt="Better Search Replace vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit