Skip to content
Laskyr

Plugins · better-search · data as of 2026-11-04

Is Better Search safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.5.4)

As of 2026-11-04. 6 issues are on record for older versions; version 4.5.3 or newer fixes all of them that state a fix.

Latest version
4.5.4
Last updated
2026-11-03
Active installs
5,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Better Search replaces the default WordPress search with a better search engine that gives contextual results sorted by relevance. — by Ajay

What to do

  1. Update to the latest version (4.5.4). Anything older than 4.5.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get better-search --field=version shows what you run; wp plugin update better-search updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-119495 · published 2026-11-03

Missing authorization check in Better Search (4.5.2 and older)

Affected
4.5.2 and older
Fixed in
4.5.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WebberZone Better Search better-search allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Better Search: from n/a through 4.5.2.

NVD CVE-2026-119495Patchstack advisory

medium 5.9 CVE-2026-24938 · published 2026-02-03

Stored cross-site scripting (XSS) in Better Search (4.2.1 and older)

Affected
4.2.1 and older
Fixed in
4.2.2
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ajay Better Search better-search allows Stored XSS.This issue affects Better Search: from n/a through <= 4.2.1.

NVD CVE-2026-24938Patchstack advisory

medium 6.5 CVE-2025-47507 · published 2025-05-07

Cross-site scripting (XSS) in Better Search (4.1.0 and older)

Affected
4.1.0 and older
Fixed in
4.1.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ajay Better Search better-search allows DOM-Based XSS.This issue affects Better Search: from n/a through <= 4.1.0.

NVD CVE-2025-47507Patchstack advisory

high 7.1 CVE-2024-29142 · published 2024-03-19

Stored cross-site scripting (XSS) in Better Search (3.3.0 and older)

Affected
3.3.0 and older
Fixed in
3.3.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WebberZone Better Search – Relevant search results for WordPress allows Stored XSS.This issue affects Better Search – Relevant search results for WordPress: from n/a through 3.3.0.

NVD CVE-2024-29142Patchstack advisory

medium 4.3 CVE-2021-4400 · published 2023-07-01

Cross-site request forgery (CSRF) in Better Search (2.5.2 and older)

Affected
2.5.2 and older
Fixed in
2.5.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Better Search plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.5.2. This is due to missing or incorrect nonce validation on the bsearch_process_settings_import() and bsearch_process_settings_export() functions. This makes it possible for unauthenticated attackers to import and export settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2021-4400Wordfence advisoryCode change (fix)blog.nintechnet.comblog.nintechnet.comblog.nintechnet.comblog.nintechnet.com

medium 4.3 CVE-2021-4373 · published 2023-06-07

Cross-site request forgery (CSRF) in Better Search (older than 2.5.3)

Affected
older than 2.5.3
Fixed in
2.5.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Better Search plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.5.2. This makes it possible for unauthenticated attackers to import settings via forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2021-4373Wordfence advisoryCode change (fix)blog.nintechnet.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Better Search vulnerability status badge
<a href="https://laskyr.com/plugins/better-search"><img src="https://laskyr.com/plugins/better-search/badge.svg" alt="Better Search vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit