Plugins · better-post-filter-widgets-for-elementor · data as of 2026-11-04
Is Better Post & Filter Widgets for Elementor safe? Known vulnerabilities and latest version
- Latest version
- 1.9.2
- Last updated
- 2026-10-25
- Active installs
- 4,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
The only free pro-grade Elementor filtering system for posts, taxonomies, custom fields, ACF, WooCommerce, WPML & more. Ditch paid limits! — by WP Smart Widgets
What to do
- Update to the latest version (1.9.2). Anything older than 1.9.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get better-post-filter-widgets-for-elementor --field=version shows what you run; wp plugin update better-post-filter-widgets-for-elementor updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-115950 · published 2026-10-26
Stored cross-site scripting (XSS) in Better Post & Filter Widgets for Elementor (1.9.1 and older)
- Affected
- 1.9.1 and older
- Fixed in
- 1.9.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Smart Widgets Better Post & Filter Widgets for Elementor better-post-filter-widgets-for-elementor allows Stored XSS.This issue affects Better Post & Filter Widgets for Elementor: from n/a through 1.9.1.
medium 6.5 CVE-2026-115949 · published 2026-10-26
Missing authorization check in Better Post & Filter Widgets for Elementor (1.9.1 and older)
- Affected
- 1.9.1 and older
- Fixed in
- 1.9.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WP Smart Widgets Better Post & Filter Widgets for Elementor better-post-filter-widgets-for-elementor allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Better Post & Filter Widgets for Elementor: from n/a through 1.9.1.
medium 6.5 CVE-2025-48354 · published 2025-08-28
Stored cross-site scripting (XSS) in Better Post & Filter Widgets for Elementor (1.6.1 and older)
- Affected
- 1.6.1 and older
- Fixed in
- 1.6.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Smart Widgets Better Post & Filter Widgets for Elementor better-post-filter-widgets-for-elementor allows Stored XSS.This issue affects Better Post & Filter Widgets for Elementor: from n/a through <= 1.6.1.
Recent activity
- 2026-10-25 — latest release on wordpress.org (1.9.2).
- 2026-10-26 — Stored cross-site scripting (XSS) disclosed (CVE-2026-115950), fixed in 1.9.2.
- 2026-10-26 — Missing authorization check disclosed (CVE-2026-115949), fixed in 1.9.2.
- 2025-08-28 — Stored cross-site scripting (XSS) disclosed (CVE-2025-48354), fixed in 1.6.2.
Get an email when Better Post & Filter Widgets for Elementor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Better Post & Filter Widgets for Elementor (better-post-filter-widgets-for-elementor) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/better-post-filter-widgets-for-elementor (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/better-post-filter-widgets-for-elementor"><img src="https://laskyr.com/plugins/better-post-filter-widgets-for-elementor/badge.svg" alt="Better Post & Filter Widgets for Elementor vulnerability status"></a>