Skip to content
Laskyr

Plugins · better-payment · data as of 2026-11-04

Is Better Payment safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.4)

As of 2026-11-04. 2 issues are on record for older versions; version 2.3.4 or newer fixes all of them that state a fix.

Latest version
2.4.4
Last updated
2026-11-02
Active installs
5,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Accept payments, donations and subscriptions, run fundraising campaigns and sell products on your Elementor and Gutenberg website. — by WPDeveloper

What to do

  1. Update to the latest version (2.4.4). Anything older than 2.3.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get better-payment --field=version shows what you run; wp plugin update better-payment updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-77765 · published 2026-09-23

Missing authorization check in Better Payment (older than 2.3.4)

Affected
older than 2.3.4
Fixed in
2.3.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Better Payment WordPress plugin before 2.3.4 does not validate the submitted payment amount server-side against the merchant's configured fixed price before building the gateway charge, allowing unauthenticated users to pay an arbitrary reduced amount for a fixed-price item.

NVD CVE-2026-77765WPScan advisory

medium 6.5 CVE-2026-57364 · published 2026-07-13

Security issue in Better Payment (2.2.0 and older)

Affected
2.2.0 and older
Fixed in
2.2.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Validation of Specified Quantity in Input vulnerability in WPDeveloper Better Payment – Instant Payments, Donations, Fundraising with Subscriptions &amp; More better-payment allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Better Payment – Instant Payments, Donations, Fundraising with Subscriptions &amp; More: from n/a through <= 2.2.0.

NVD CVE-2026-57364Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Better Payment vulnerability status badge
<a href="https://laskyr.com/plugins/better-payment"><img src="https://laskyr.com/plugins/better-payment/badge.svg" alt="Better Payment vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit