Plugins · better-elementor-addons · data as of 2026-11-04
Is Better Addons for Elementor safe? Known vulnerabilities and latest version
- Latest version
- 1.5.7
- Last updated
- 2026-01-19
- Active installs
- 4,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 6.8.12 · PHP 7.4+
Showcase useful elements with card style for elementor page builder. — by wpdive
What to do
- Update to the latest version (1.5.7). Anything older than 1.5.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get better-elementor-addons --field=version shows what you run; wp plugin update better-elementor-addons updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2023-41656 · published 2025-12-30
Missing authorization check in Better Addons for Elementor (1.3.7 and older)
- Affected
- 1.3.7 and older
- Fixed in
- 1.3.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in wpdive Better Elementor Addons allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Better Elementor Addons: from n/a through 1.3.7.
medium 6.4 CVE-2025-12830 · published 2025-12-12
Stored cross-site scripting (XSS) in Better Addons for Elementor (1.5.5 and older)
- Affected
- 1.5.5 and older
- Fixed in
- 1.5.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Better Elementor Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Slider widget in all versions up to, and including, 1.5.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-12830Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 6.5 CVE-2024-33541 · published 2024-06-04
File inclusion in Better Addons for Elementor (1.4.1 and older)
- Affected
- 1.4.1 and older
- Fixed in
- 1.4.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in BetterAddons Better Elementor Addons allows PHP Local File Inclusion.This issue affects Better Elementor Addons: from n/a through 1.4.1.
medium 5.4 CVE-2024-34432 · published 2024-05-14
Stored cross-site scripting (XSS) in Better Addons for Elementor (1.4.4 and older)
- Affected
- 1.4.4 and older
- Fixed in
- 1.4.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BetterAddons Better Elementor Addons better-elementor-addons allows Stored XSS.This issue affects Better Elementor Addons: from n/a through 1.4.4.
medium 5.4 CVE-2024-30423 · published 2024-03-29
Stored cross-site scripting (XSS) in Better Addons for Elementor (1.3.7 and older)
- Affected
- 1.3.7 and older
- Fixed in
- 1.3.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BetterAddons Better Elementor Addons allows Stored XSS.This issue affects Better Elementor Addons: from n/a through 1.3.7.
medium 5.4 CVE-2024-2280 · published 2024-03-29
Stored cross-site scripting (XSS) in Better Addons for Elementor (1.4.1 and older)
- Affected
- 1.4.1 and older
- Fixed in
- 1.5.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Better Elementor Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the widget link URL values in all versions up to, and including, 1.4.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-2280Wordfence advisoryCode change (fix)wordpress.org
Recent activity
- 2026-01-19 — latest release on wordpress.org (1.5.7).
- 2025-12-30 — Missing authorization check disclosed (CVE-2023-41656), fixed in 1.3.9.
- 2025-12-12 — Stored cross-site scripting (XSS) disclosed (CVE-2025-12830), fixed in 1.5.6.
- 2024-06-04 — File inclusion disclosed (CVE-2024-33541), fixed in 1.4.2.
Get an email when Better Addons for Elementor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Better Addons for Elementor (better-elementor-addons) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by wpdive (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (4) · Missing authorization (1) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/better-elementor-addons (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/better-elementor-addons"><img src="https://laskyr.com/plugins/better-elementor-addons/badge.svg" alt="Better Addons for Elementor vulnerability status"></a>