Skip to content
Laskyr

Plugins · best-woocommerce-feed · data as of 2026-11-04

Is Product Feed Manager for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.14.3)

As of 2026-11-04. 6 issues are on record for older versions; version 7.14.2 or newer fixes all of them that state a fix.

Latest version
7.14.3
Last updated
2026-10-30
Active installs
10,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Generate WooCommerce product feeds for 200+ marketplaces. Sell on Google Shopping, Facebook, Instagram, Amazon, eBay, TikTok and more. — by RexTheme

What to do

  1. Update to the latest version (7.14.3). Anything older than 7.14.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get best-woocommerce-feed --field=version shows what you run; wp plugin update best-woocommerce-feed updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-118089 · published 2026-10-30

PHP object injection in Product Feed Manager for WooCommerce (7.14.1 and older)

Affected
7.14.1 and older
Fixed in
7.14.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Shop manager PHP Object Injection in Product Feed Manager <= 7.14.1 versions.

NVD CVE-2026-118089Patchstack advisory

medium 5.3 CVE-2026-118093 · published 2026-10-29

Missing authorization check in Product Feed Manager for WooCommerce (7.14.1 and older)

Affected
7.14.1 and older
Fixed in
7.14.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPFunnels Team Product Feed Manager best-woocommerce-feed allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Product Feed Manager: from n/a through 7.14.1.

NVD CVE-2026-118093Patchstack advisory

high 8.5 CVE-2026-66580 · published 2026-09-17

SQL injection in Product Feed Manager for WooCommerce (7.12.0 and older)

Affected
7.12.0 and older
Fixed in
7.12.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor SQL Injection in Product Feed Manager <= 7.12.0 versions.

NVD CVE-2026-66580Patchstack advisory

high 7.1 CVE-2026-59553 · published 2026-07-27

Cross-site scripting (XSS) in Product Feed Manager for WooCommerce (7.6.1 and older)

Affected
7.6.1 and older
Fixed in
7.6.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Product Feed Manager <= 7.6.1 versions.

NVD CVE-2026-59553Patchstack advisory

medium 6.1 CVE-2026-15306 · published 2026-07-16

Reflected cross-site scripting (XSS) in Product Feed Manager for WooCommerce (7.6.1 and older)

Affected
7.6.1 and older
Fixed in
7.6.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Product Feed Manager For WooCommerce – Sell on 200+ Online Marketplaces plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via 's' Search Parameter in all versions up to, and including, 7.6.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2026-15306Wordfence advisoryCode change (fix)Plugin source

medium 5.5 CVE-2023-52144 · published 2024-04-15

Path traversal / file read in Product Feed Manager for WooCommerce (7.3.15 and older)

Affected
7.3.15 and older
Fixed in
7.3.16
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in RexTheme Product Feed Manager.This issue affects Product Feed Manager: from n/a through 7.3.15.

NVD CVE-2023-52144Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Product Feed Manager for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/best-woocommerce-feed"><img src="https://laskyr.com/plugins/best-woocommerce-feed/badge.svg" alt="Product Feed Manager for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit