Skip to content
Laskyr

Plugins · before-after-image-compare · data as of 2026-11-04

Is Before After Image Comparison safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.22)

As of 2026-11-04. 2 issues are on record for older versions; version 1.1.22 or newer fixes all of them that state a fix.

Latest version
1.1.22
Last updated
2026-11-03
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.2+

Easily showcase visual differences between two images with an interactive before-and-after slider – no coding required! — by bPlugins

What to do

  1. Update to the latest version (1.1.22). Anything older than 1.1.22 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get before-after-image-compare --field=version shows what you run; wp plugin update before-after-image-compare updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-62034 · published 2026-10-10

Cross-site scripting (XSS) in Before After Image Comparison (1.1.21 and older)

Affected
1.1.21 and older
Fixed in
1.1.22 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Before After Image Comparison – Image comparison for WP <= 1.1.21 versions.

NVD CVE-2026-62034Patchstack advisory

medium 5.4 CVE-2026-62028 · published 2026-10-09

Missing authorization check in Before After Image Comparison (1.1.21 and older)

Affected
1.1.21 and older
Fixed in
1.1.22 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in bPlugins Before After Image Comparison – Image comparison for WP before-after-image-compare allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Before After Image Comparison – Image comparison for WP: from n/a through 1.1.21.

NVD CVE-2026-62028Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Before After Image Comparison vulnerability status badge
<a href="https://laskyr.com/plugins/before-after-image-compare"><img src="https://laskyr.com/plugins/before-after-image-compare/badge.svg" alt="Before After Image Comparison vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit