Skip to content
Laskyr

Plugins · bcs-mcp-manager · data as of 2026-11-04

Is ByteCoreStack safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.0)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.4 or newer fixes all of them that state a fix.

Latest version
1.3.0
Last updated
2026-10-24
Active installs
20+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Connect Claude, ChatGPT and other AI clients to WordPress with MCP, OAuth 2.0, and 360 tools for content, WooCommerce and SEO. — by ByteCore Stack

What to do

  1. Update to the latest version (1.3.0). Anything older than 1.2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bcs-mcp-manager --field=version shows what you run; wp plugin update bcs-mcp-manager updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-103068 · published 2026-10-01

Privilege escalation in ByteCoreStack (1.2.2 and older)

Affected
1.2.2 and older
Fixed in
1.2.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Privilege Escalation in ByteCoreStack &#8211; MCP Connector for AI Tools <= 1.2.2 versions.

NVD CVE-2026-103068Patchstack advisory

high 8.8 CVE-2026-19807 · published 2026-10-01

Privilege escalation in ByteCoreStack (1.2.3 and older)

Affected
1.2.3 and older
Fixed in
1.2.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ByteCoreStack – MCP Connector for AI Tools plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.2.3 This is due to the `wp_update_user_meta` MCP tool in `execute_tool` gating writes solely with `current_user_can('edit_user', $uid)` — a check that WordPress core's `map_meta_cap` resolves to the `read` primitive when the target user ID matches the caller's own — while enforcing an incomplete meta key blocklist that covers only `user_pass`, `user_activation_key`, and `session_tokens`, leaving the `wp_capabilities` and `wp_user_level` meta keys entirely unprotected. This makes it possible for authenticated attackers with Subscriber-level access and above to elevate their privileges to Administrator by issuing a `wp_update_user_meta` call over the MCP JSON-RPC endpoint with `key=wp_capabilities` and an arbitrary role array such as `{'administrator': true}` targeting their own user ID, causing WordPress to load that account as an Administrator on the next request.

NVD CVE-2026-19807Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ByteCoreStack vulnerability status badge
<a href="https://laskyr.com/plugins/bcs-mcp-manager"><img src="https://laskyr.com/plugins/bcs-mcp-manager/badge.svg" alt="ByteCoreStack vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit