Skip to content
Laskyr

Plugins · bbpress · data as of 2026-11-04

Is bbPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.6.21)

As of 2026-11-04. 5 issues are on record for older versions; version 2.6.15 or newer fixes all of them that state a fix.

Latest version
2.6.21
Last updated
2026-10-27
Active installs
100,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

bbPress is forum software for WordPress. — by John James Jacoby

What to do

  1. Update to the latest version (2.6.21). Anything older than 2.6.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bbpress --field=version shows what you run; wp plugin update bbpress updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-62137 · published 2026-09-11

Information disclosure in bbPress (2.6.14 and older)

Affected
2.6.14 and older
Fixed in
2.6.15
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Sensitive Data Exposure in bbPress <= 2.6.14 versions.

NVD CVE-2026-62137Patchstack advisory

medium 5.3 CVE-2026-74010 · published 2026-08-31

Missing authorization check in bbPress (2.6.14 and older)

Affected
2.6.14 and older
Fixed in
2.6.15 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in John James Jacoby bbPress allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects bbPress: from n/a through 2.6.14.

NVD CVE-2026-74010Patchstack advisory

medium 6.3 CVE-2025-1435 · published 2025-03-05

Cross-site request forgery (CSRF) in bbPress (2.6.11 and older)

Affected
2.6.11 and older
Fixed in
2.6.12 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The bbPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.6.11. This is due to missing or incorrect nonce validation on the bbp_user_add_role_on_register() function. This makes it possible for unauthenticated attackers to elevate their privileges to that of a bbPress Keymaster via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Rather than implementing a nonce check to provide protection against this vulnerability, which would break functionality, the plugin no longer makes it possible to select a role during registration.

NVD CVE-2025-1435Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2020-13693 · published 2020-05-29

Security issue in bbPress (older than 2.6.5)

Affected
older than 2.6.5
Fixed in
2.6.5
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

An unauthenticated privilege-escalation issue exists in the bbPress plugin before 2.6.5 for WordPress when New User Registration is enabled.

NVD CVE-2020-13693wordpress.orgpacketstormsecurity.combbpress.orgcodex.bbpress.org

medium 4.8 CVE-2020-13487 · published 2020-05-26

Stored cross-site scripting (XSS) in bbPress (2.6.4 and older)

Affected
2.6.4 and older
Fixed in
2.6.5 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The bbPress plugin through 2.6.4 for WordPress has stored XSS in the Forum creation section, resulting in JavaScript execution at wp-admin/edit.php?post_type=forum (aka the Forum listing page) for all users. An administrator can exploit this at the wp-admin/post.php?action=edit URI.

NVD CVE-2020-13487wordpress.orgbbpress.orgcodex.bbpress.orgyoutube.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
bbPress vulnerability status badge
<a href="https://laskyr.com/plugins/bbpress"><img src="https://laskyr.com/plugins/bbpress/badge.svg" alt="bbPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit