Skip to content
Laskyr

Plugins · bbp-style-pack · data as of 2026-11-04

Is bbp style pack safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.5.3)

As of 2026-11-04. 4 issues are on record for older versions; version 6.4.9 or newer fixes all of them that state a fix.

Latest version
6.5.3
Last updated
2026-10-16
Active installs
6,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

For bbPress - Lets you style bbPress, and add display features — by Robin W

What to do

  1. Update to the latest version (6.5.3). Anything older than 6.4.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bbp-style-pack --field=version shows what you run; wp plugin update bbp-style-pack updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-101925 · published 2026-10-01

Stored cross-site scripting (XSS) in bbp style pack (6.4.8 and older)

Affected
6.4.8 and older
Fixed in
6.4.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The bbp style pack plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display_name (via /wp-admin/profile.php) + bbp_reply_content (via bbPress reply form)' parameter in all versions up to, and including, 6.4.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires the attacker to wrap their crafted reply in a <pre> block, which prevents WordPress's wpautop/wptexturize processors from converting straight double quotes in the stored display name into typographic curly-quote entities that would otherwise neutralize the attribute-injection.

NVD CVE-2026-101925Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2026-15010 · published 2026-07-11

Stored cross-site scripting (XSS) in bbp style pack (6.4.5 and older)

Affected
6.4.5 and older
Fixed in
6.4.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The bbp Style Pack plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 6.4.5 via the Topic Form Additional Fields feature. This is due to insufficient input sanitization in bsp_topic_fields_form_save() (which writes $_POST['bsp_topic_fields_label{n}'] directly to post meta via update_post_meta() with no filtering) and missing output escaping in bsp_topic_content_append_topic_fields() (which concatenates the stored meta value into an HTML <span> and echoes it via apply_filters/echo without esc_html()). This makes it possible for authenticated attackers, with Subscriber-level access and above (who have bbPress topic-creation privileges), to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page, including unauthenticated visitors.

NVD CVE-2026-15010Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2023-44984 · published 2023-10-16

Stored cross-site scripting (XSS) in bbp style pack (5.6.7 and older)

Affected
5.6.7 and older
Fixed in
5.6.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Robin Wilson bbp style pack plugin <= 5.6.7 versions.

NVD CVE-2023-44984Patchstack advisory

medium 6.1 CVE-2023-33997 · published 2023-06-22

Reflected cross-site scripting (XSS) in bbp style pack (5.5.5 and older)

Affected
5.5.5 and older
Fixed in
5.5.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Robin Wilson bbp style pack plugin <= 5.5.5 versions.

NVD CVE-2023-33997Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
bbp style pack vulnerability status badge
<a href="https://laskyr.com/plugins/bbp-style-pack"><img src="https://laskyr.com/plugins/bbp-style-pack/badge.svg" alt="bbp style pack vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit