Plugins · bbp-core · data as of 2026-11-04
Is Forumax safe? Known vulnerabilities and latest version
- Latest version
- 2.5.2
- Last updated
- 2026-11-03
- Active installs
- 500+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Build powerful communities with Forumax. A fully standalone, feature-rich forum plugin with voting, private replies, and Elementor integration. — by Spider Themes
What to do
- Update to the latest version (2.5.2). Anything older than 2.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get bbp-core --field=version shows what you run; wp plugin update bbp-core updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-68572 · published 2025-12-24
Missing authorization check in Forumax (1.4.1 and older)
- Affected
- 1.4.1 and older
- Fixed in
- 2.0.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Spider Themes BBP Core bbp-core allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects BBP Core: from n/a through <= 1.4.1.
medium 6.1 CVE-2024-9896 · published 2024-11-02
Reflected cross-site scripting (XSS) in Forumax (1.2.5 and older)
- Affected
- 1.2.5 and older
- Fixed in
- 1.2.6 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The BBP Core – Expand bbPress powered forums with useful features plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.2.5. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-9896Wordfence advisoryCode change (fix)wordpress.orgPlugin source
Recent activity
- 2026-11-03 — latest release on wordpress.org (2.5.2).
- 2025-12-24 — Missing authorization check disclosed (CVE-2025-68572), fixed in 2.0.0.
- 2024-11-02 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-9896), fixed in 1.2.6.
Get an email when Forumax has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Forumax (bbp-core) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/bbp-core (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/bbp-core"><img src="https://laskyr.com/plugins/bbp-core/badge.svg" alt="Forumax vulnerability status"></a>