Skip to content
Laskyr

Plugins · bayarcash-wc · data as of 2026-11-04

Is Bayarcash WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.4.3)

As of 2026-11-04. 2 issues are on record for older versions; version 4.4.3 or newer fixes all of them that state a fix.

Latest version
4.4.3
Last updated
2026-10-08
Active installs
700+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Accept online payment & QR from Malaysia. Currently, Bayarcash support FPX, Direct Debit, DuitNow, Credit Card, Boost, GrabPay, ShopeePay, Touch & … — by Bayarcash

What to do

  1. Update to the latest version (4.4.3). Anything older than 4.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get bayarcash-wc --field=version shows what you run; wp plugin update bayarcash-wc updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-106609 · published 2026-10-10

Missing authorization check in Bayarcash WooCommerce (4.4.2 and older)

Affected
4.4.2 and older
Fixed in
4.4.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Web Impian Bayarcash WooCommerce bayarcash-wc allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Bayarcash WooCommerce: from n/a through 4.4.2.

NVD CVE-2026-106609Patchstack advisory

medium 5.3 CVE-2026-24606 · published 2026-01-23

Missing authorization check in Bayarcash WooCommerce (4.3.13 and older)

Affected
4.3.13 and older
Fixed in
4.3.14
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Web Impian Bayarcash WooCommerce bayarcash-wc allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Bayarcash WooCommerce: from n/a through <= 4.3.13.

NVD CVE-2026-24606Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Bayarcash WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/bayarcash-wc"><img src="https://laskyr.com/plugins/bayarcash-wc/badge.svg" alt="Bayarcash WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit