Skip to content
Laskyr

Plugins · basticom-framework · data as of 2026-11-04

Is Basticom Framework safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.3)

As of 2026-11-04. 2 issues are on record for older versions; version 1.5.3 or newer fixes all of them that state a fix.

Latest version
1.5.3
Last updated
2026-01-09
Active installs
100+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.6.11 · PHP 7.2+

The Basticom framework plugin allows you to modify certain core functions of Wordpress as well as fine-tune some additional settings. — by Basticom

What to do

  1. Update to the latest version (1.5.3). Anything older than 1.5.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get basticom-framework --field=version shows what you run; wp plugin update basticom-framework updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2025-67629 · published 2025-12-24

Stored cross-site scripting (XSS) in Basticom Framework (1.5.2 and older)

Affected
1.5.2 and older
Fixed in
1.5.3
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Basticom Basticom Framework basticom-framework allows Stored XSS.This issue affects Basticom Framework: from n/a through <= 1.5.2.

NVD CVE-2025-67629Patchstack advisory

medium 5.4 CVE-2024-9443 · published 2024-11-05

Stored cross-site scripting (XSS) in Basticom Framework (1.5.0 and older)

Affected
1.5.0 and older
Fixed in
1.5.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Basticom Framework plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.5.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.

NVD CVE-2024-9443Wordfence advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Basticom Framework vulnerability status badge
<a href="https://laskyr.com/plugins/basticom-framework"><img src="https://laskyr.com/plugins/basticom-framework/badge.svg" alt="Basticom Framework vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit