Skip to content
Laskyr

Plugins · basic-google-maps-placemarks · data as of 2026-11-04

Is Basic Google Maps Placemarks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.10.8)

As of 2026-11-04. 1 issue is on record for older versions; version 1.10.8 or newer fixes all of them that state a fix.

Latest version
1.10.8
Last updated
2026-03-31
Active installs
2,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11

Embeds a Google Map into your site and lets you add map markers with custom icons and information windows. — by Ian Dunn

What to do

  1. Update to the latest version (1.10.8). Anything older than 1.10.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get basic-google-maps-placemarks --field=version shows what you run; wp plugin update basic-google-maps-placemarks updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-3581 · published 2026-04-16

Missing authorization check in Basic Google Maps Placemarks (1.10.7 and older)

Affected
1.10.7 and older
Fixed in
1.10.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Basic Google Maps Placemarks plugin for WordPress is vulnerable to authorization bypass in versions up to, and including, 1.10.7. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to modify stored map latitude and longitude options.

NVD CVE-2026-3581Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Basic Google Maps Placemarks vulnerability status badge
<a href="https://laskyr.com/plugins/basic-google-maps-placemarks"><img src="https://laskyr.com/plugins/basic-google-maps-placemarks/badge.svg" alt="Basic Google Maps Placemarks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit