Plugins · basepress · data as of 2026-11-04
Is Knowledge Base documentation & wiki plugin safe? Known vulnerabilities and latest version
- Latest version
- 2.17.0.3
- Last updated
- 2026-08-12
- Active installs
- 2,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
Easily create & manage documentation. Reduce support tickets & scale your customer support workload. This simple plugin works with any theme. — by BasePress
What to do
- Update to the latest version (2.17.0.3). Anything older than 2.17.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get basepress --field=version shows what you run; wp plugin update basepress updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2025-62761 · published 2025-12-31
Stored cross-site scripting (XSS) in Knowledge Base documentation & wiki plugin (2.17.0.1 and older)
- Affected
- 2.17.0.1 and older
- Fixed in
- 2.17.0.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BasePress Knowledge Base documentation & wiki plugin – BasePress basepress allows Stored XSS.This issue affects Knowledge Base documentation & wiki plugin – BasePress: from n/a through <= 2.17.0.1.
medium 4.3 CVE-2024-10664 · published 2024-12-04
Missing authorization check in Knowledge Base documentation & wiki plugin (2.16.3.3 and older)
- Affected
- 2.16.3.3 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Knowledge Base documentation & wiki plugin – BasePress Docs plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the basepress_db_posts_update() function in all versions up to, and including, 2.16.3.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update the database.
medium 5.4 CVE-2024-33588 · published 2024-04-29
Missing authorization check in Knowledge Base documentation & wiki plugin (2.16.1 and older)
- Affected
- 2.16.1 and older
- Fixed in
- 2.16.2.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in codeSavory Knowledge Base documentation & wiki plugin – BasePress.This issue affects Knowledge Base documentation & wiki plugin – BasePress: from n/a through 2.16.1.
medium 5.0 CVE-2024-33590 · published 2024-04-29
Server-side request forgery (SSRF) in Knowledge Base documentation & wiki plugin (2.16.1 and older)
- Affected
- 2.16.1 and older
- Fixed in
- 2.16.2.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in codeSavory Knowledge Base documentation & wiki plugin – BasePress.This issue affects Knowledge Base documentation & wiki plugin – BasePress: from n/a through 2.16.1.
Recent activity
- 2026-08-12 — latest release on wordpress.org (2.17.0.3).
- 2025-12-31 — Stored cross-site scripting (XSS) disclosed (CVE-2025-62761), fixed in 2.17.0.2.
- 2024-12-04 — Missing authorization check disclosed (CVE-2024-10664), fix version not stated.
- 2024-04-29 — Missing authorization check disclosed (CVE-2024-33588), fixed in 2.16.2.1.
Get an email when Knowledge Base documentation & wiki plugin has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Knowledge Base documentation & wiki plugin (basepress) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1) · Server-side request forgery (SSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/basepress (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/basepress"><img src="https://laskyr.com/plugins/basepress/badge.svg" alt="Knowledge Base documentation & wiki plugin vulnerability status"></a>