Skip to content
Laskyr

Plugins · banner-management-for-woocommerce · data as of 2026-11-04

Is Banner Management For WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.3)

As of 2026-11-04. 3 issues are on record for older versions; version 2.5.2 or newer fixes all of them that state a fix.

Latest version
2.5.3
Last updated
2026-10-29
Active installs
2,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.2+

Allows you to set single or multiple banners on the WooCommerce category and page. — by Dotstore

What to do

  1. Update to the latest version (2.5.3). Anything older than 2.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get banner-management-for-woocommerce --field=version shows what you run; wp plugin update banner-management-for-woocommerce updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-22354 · published 2026-02-20

PHP object injection in Banner Management For WooCommerce (2.5.1 and older)

Affected
2.5.1 and older
Fixed in
2.5.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Dotstore Woocommerce Category Banner Management banner-management-for-woocommerce allows Object Injection.This issue affects Woocommerce Category Banner Management: from n/a through <= 2.5.1.

NVD CVE-2026-22354Patchstack advisory

medium 6.5 CVE-2023-39158 · published 2023-10-03

Cross-site request forgery (CSRF) in Banner Management For WooCommerce (2.4.2 and older)

Affected
2.4.2 and older
Fixed in
2.4.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in theDotstore Banner Management For WooCommerce plugin <= 2.4.2 versions.

NVD CVE-2023-39158Patchstack advisory

medium 5.3 CVE-2018-11579 · published 2018-05-31

Authentication bypass in Banner Management For WooCommerce (1.1.0 only)

Affected
1.1.0 only
Fixed in
1.1.1 *
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

class-woo-banner-management.php in the MULTIDOTS WooCommerce Category Banner Management plugin 1.1.0 for WordPress has an Unauthenticated Settings Change Vulnerability, related to certain wp_ajax_nopriv_ usage. Anyone can change the plugin's setting by simply sending a request with a wbm_save_shop_page_banner_data action.

NVD CVE-2018-11579wordpress.orglabs.threatpress.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Banner Management For WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/banner-management-for-woocommerce"><img src="https://laskyr.com/plugins/banner-management-for-woocommerce/badge.svg" alt="Banner Management For WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit