Plugins · bakkbone-florist-companion · data as of 2026-11-04
Is FloristPress for Woo safe? Known vulnerabilities and latest version
- Latest version
- 7.8.5
- Last updated
- 2026-11-01
- Active installs
- 10+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 8.1+
Provides standardized features for floristry websites – built by florists, for florists. — by BAKKBONE Australia
What to do
- Update to the latest version (7.8.5). Anything older than 7.8.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get bakkbone-florist-companion --field=version shows what you run; wp plugin update bakkbone-florist-companion updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2026-1986 · published 2026-03-26
Reflected cross-site scripting (XSS) in FloristPress for Woo (7.8.2 and older)
- Affected
- 7.8.2 and older
- Fixed in
- 7.8.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The FloristPress for Woo – Customize your eCommerce store for your Florist plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'noresults' parameter in all versions up to, and including, 7.8.2 due to insufficient input sanitization and output escaping on the user supplied 'noresults' parameter. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2026-1986Wordfence advisoryCode change (fix)Plugin source
high 7.1 CVE-2024-54347 · published 2024-12-13
Reflected cross-site scripting (XSS) in FloristPress for Woo (7.2.0 and older)
- Affected
- 7.2.0 and older
- Fixed in
- 7.3.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BAKKBONE Australia FloristPress bakkbone-florist-companion allows Reflected XSS.This issue affects FloristPress: from n/a through <= 7.2.0.
medium 5.4 CVE-2024-53798 · published 2024-12-09
Missing authorization check in FloristPress for Woo (7.3.0 and older)
- Affected
- 7.3.0 and older
- Fixed in
- 7.4.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in BAKKBONE Australia FloristPress bakkbone-florist-companion.This issue affects FloristPress: from n/a through <= 7.3.0.
medium 4.3 CVE-2024-53799 · published 2024-12-06
Missing authorization check in FloristPress for Woo (7.3.0 and older)
- Affected
- 7.3.0 and older
- Fixed in
- 7.4.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in BAKKBONE Australia FloristPress bakkbone-florist-companion allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects FloristPress: from n/a through <= 7.3.0.
Recent activity
- 2026-11-01 — latest release on wordpress.org (7.8.5).
- 2026-03-26 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-1986), fixed in 7.8.3.
- 2024-12-13 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-54347), fixed in 7.3.0.
- 2024-12-09 — Missing authorization check disclosed (CVE-2024-53798), fixed in 7.4.0.
Get an email when FloristPress for Woo has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for FloristPress for Woo (bakkbone-florist-companion) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/bakkbone-florist-companion (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/bakkbone-florist-companion"><img src="https://laskyr.com/plugins/bakkbone-florist-companion/badge.svg" alt="FloristPress for Woo vulnerability status"></a>