Skip to content
Laskyr

Plugins · backuply · data as of 2026-11-01

Is Backuply safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.0)

As of 2026-11-01. 6 issues are on record for older versions; version 1.5.9 or newer fixes all of them that state a fix.

Latest version
1.6.0
Last updated
2026-10-22
Active installs
600,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.5+

Backup, restores, and migration with Backuply are fairly simple with a wide range of storage options from Local Backups, FTP to cloud options like AWS … — by Softaculous

What to do

  1. Update to the latest version (1.6.0). Anything older than 1.5.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get backuply --field=version shows what you run; wp plugin update backuply updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.0 CVE-2026-93953 · published 2026-10-16

SQL injection in Backuply (1.5.8 and older)

Affected
1.5.8 and older
Fixed in
1.5.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Backuply – Backup, Restore, Migrate and Clone plugin for WordPress is vulnerable to SQL Injection via the Biographical Info field (second-order, via restore) in all versions up to, and including, 1.5.8 due to insufficient escaping on the user supplied parameter and the lack of sufficient preparation on an existing SQL query. Backuply exports the Biographical Info value verbatim inside an INSERT statement written to the backup's SQL dump (wp_usermeta). When an Administrator later restores such a backup, the crafted payload breaks out of that INSERT statement and appends attacker-controlled SQL that executes with full database privileges. This makes it possible for authenticated attackers, with subscriber-level access and above, to write arbitrary data to the database — in particular to update the default_role option in wp_options to administrator (and enable open user registration) — so that a subsequently registered account is automatically granted the Administrator role, resulting in privilege escalation and full site takeover. Because the injection executes inside an INSERT during restore with no response returned to the attacker, the primitive is used to modify database records rather than to read existing data directly.

NVD CVE-2026-93953Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-10307 · published 2025-09-26

Arbitrary file deletion in Backuply (1.4.8 and older)

Affected
1.4.8 and older
Fixed in
1.4.9 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Backuply – Backup, Restore, Migrate and Clone plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the delete backup functionality in all versions up to, and including, 1.4.8. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).

NVD CVE-2025-10307Wordfence advisoryCode change (fix)

high 7.2 CVE-2024-8669 · published 2024-09-14

SQL injection in Backuply (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.3.5 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Backuply – Backup, Restore, Migrate and Clone plugin for WordPress is vulnerable to SQL Injection via the 'options' parameter passed to the backuply_wp_clone_sql() function in all versions up to, and including, 1.3.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2024-8669Wordfence advisoryCode change (fix)Plugin source

medium 4.9 CVE-2024-2294 · published 2024-03-16

Path traversal / file read in Backuply (1.2.7 and older)

Affected
1.2.7 and older
Fixed in
1.3.4 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Backuply – Backup, Restore, Migrate and Clone plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 1.2.7 via the backup_name parameter in the backuply_download_backup function. This makes it possible for attackers to have an account with only activate_plugins capability to access arbitrary files on the server, which can contain sensitive information. This only impacts sites hosted on Windows servers.

NVD CVE-2024-2294Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2024-0842 · published 2024-02-09

Denial of service in Backuply (1.2.6 and older)

Affected
1.2.6 and older
Fixed in
1.3.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Backuply – Backup, Restore, Migrate and Clone plugin for WordPress is vulnerable to Denial of Service in all versions up to, and including, 1.2.6. This is due to direct access of the backuply/restore_ins.php file and. This makes it possible for unauthenticated attackers to make excessive requests that result in the server running out of resources.

NVD CVE-2024-0842Wordfence advisoryCode change (fix)

medium 4.9 CVE-2024-0697 · published 2024-01-27

Path traversal / file read in Backuply (1.2.3 and older)

Affected
1.2.3 and older
Fixed in
1.2.6 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Backuply – Backup, Restore, Migrate and Clone plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 1.2.3 via the node_id parameter in the backuply_get_jstree function. This makes it possible for attackers with administrator privileges or higher to read the contents of arbitrary files on the server, which can contain sensitive information.

NVD CVE-2024-0697Wordfence advisoryCode change (fix)

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Backuply vulnerability status badge
<a href="https://laskyr.com/plugins/backuply"><img src="https://laskyr.com/plugins/backuply/badge.svg" alt="Backuply vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit