Skip to content
Laskyr

Plugins · backup · data as of 2026-11-04

Is JetBackup safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.24.10)

As of 2026-11-04. 7 issues are on record for older versions; version 3.1.20.3 or newer fixes all of them that state a fix.

Latest version
3.1.24.10
Last updated
2026-10-18
Active installs
200,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Backup, restore, and migrate WordPress sites fast. Supports TAR, remote backups, multi schedules, and full multisite compatibility. — by JetBackup

What to do

  1. Update to the latest version (3.1.24.10). Anything older than 3.1.20.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get backup --field=version shows what you run; wp plugin update backup updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2026-4853 · published 2026-04-17

Path traversal / file read in JetBackup (3.1.19.8 and older)

Affected
3.1.19.8 and older
Fixed in
3.1.20.3 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The JetBackup – Backup, Restore & Migrate plugin for WordPress is vulnerable to Path Traversal leading to Arbitrary Directory Deletion in versions up to and including 3.1.19.8. This is due to insufficient input validation on the fileName parameter in the file upload handler. The plugin sanitizes the fileName parameter using sanitize_text_field(), which removes HTML tags but does not prevent path traversal sequences like '../'. The unsanitized filename is then directly concatenated in Upload::getFileLocation() without using basename() or validating the resolved path stays within the intended directory. When an invalid file is uploaded, the cleanup logic calls dirname() on the traversed path and passes it to Util::rm(), which recursively deletes the entire resolved directory. This makes it possible for authenticated attackers with administrator-level access to traverse outside the intended upload directory and trigger deletion of critical WordPress directories such as wp-content/plugins, effectively disabling all installed plugins and causing severe site disruption.

NVD CVE-2026-4853Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2022-34148 · published 2023-03-15

Cross-site scripting (XSS) in JetBackup (1.6.9.0 and older)

Affected
1.6.9.0 and older
Fixed in
1.6.9.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in JetBackup JetBackup – WP Backup, Migrate & Restore plugin <= 1.6.9.0 versions.

NVD CVE-2022-34148Patchstack advisory

medium 5.4 CVE-2020-36667 · published 2023-03-07

Information disclosure in JetBackup (1.4.0 and older)

Affected
1.4.0 and older
Fixed in
1.4.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The JetBackup – WP Backup, Migrate & Restore plugin for WordPress is vulnerable to unauthorized back-up location changes in versions up to, and including 1.4.1 due to a lack of proper capability checking on the backup_guard_cloud_dropbox, backup_guard_cloud_gdrive, and backup_guard_cloud_oneDrive functions. This makes it possible for authenticated attackers, with minimal permissions, such as a subscriber to change to location of back-ups and potentially steal sensitive information from them.

NVD CVE-2020-36667Wordfence advisoryCode change (fix)

medium 4.3 CVE-2020-36668 · published 2023-03-07

Information disclosure in JetBackup (1.4.0 and older)

Affected
1.4.0 and older
Fixed in
1.4.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The JetBackup – WP Backup, Migrate & Restore plugin for WordPress is vulnerable to sensitive information disclosure in versions up to, and including, 1.4.0 due to a lack of proper capability checking on the backup_guard_get_manual_modal function called via an AJAX action. This makes it possible for subscriber-level attackers, and above, to invoke the function and obtain database table information.

NVD CVE-2020-36668Wordfence advisoryCode change (fix)

high 8.8 CVE-2020-36669 · published 2023-03-07

Cross-site request forgery (CSRF) in JetBackup (1.3.9 and older)

Affected
1.3.9 and older
Fixed in
1.4.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The JetBackup – WP Backup, Migrate & Restore plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including 1.3.9. This is due to missing nonce validation on the backup_guard_get_import_backup() function. This makes it possible for unauthenticated attackers to upload arbitrary files to the vulnerable site's server via a forged request, granted they can trick a site's administrator into performing an action such as clicking on a link.

NVD CVE-2020-36669Wordfence advisoryCode change (fix)

medium 6.1 CVE-2017-18488 · published 2019-08-13

Cross-site scripting (XSS) in JetBackup (older than 1.1.47)

Affected
older than 1.1.47
Fixed in
1.1.47
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The Backup Guard plugin before 1.1.47 for WordPress has multiple XSS issues.

NVD CVE-2017-18488wordpress.org

medium 6.1 CVE-2017-10837 · published 2017-08-29

Cross-site scripting (XSS) in JetBackup (1.1.46 and older)

Affected
1.1.46 and older
Fixed in
1.1.90 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

Cross-site scripting vulnerability in BackupGuard prior to version 1.1.47 allows an attacker to inject arbitrary web script or HTML via unspecified vectors.

NVD CVE-2017-10837wordpress.orgjvn.jp

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
JetBackup vulnerability status badge
<a href="https://laskyr.com/plugins/backup"><img src="https://laskyr.com/plugins/backup/badge.svg" alt="JetBackup vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit