Skip to content
Laskyr

Plugins · b-carousel-block · data as of 2026-11-04

Is Carousel Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.3)

As of 2026-11-04. 1 issue is on record for older versions; version 1.1.6 or newer fixes all of them that state a fix.

Latest version
1.2.3
Last updated
2026-08-30
Active installs
7,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Create responsive image and content carousels in Gutenberg. Captions, autoplay, effects, navigation – build elegant sliders with no code. — by bPlugins

What to do

  1. Update to the latest version (1.2.3). Anything older than 1.1.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get b-carousel-block --field=version shows what you run; wp plugin update b-carousel-block updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-12388 · published 2025-11-05

Server-side request forgery (SSRF) in Carousel Block (1.1.5 and older)

Affected
1.1.5 and older
Fixed in
1.1.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The B Carousel Block – Responsive Image and Content Carousel plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including, 1.1.5. This is due to the plugin not validating user-supplied URLs before passing them to the wp_remote_request() function. This makes it possible for authenticated attackers, with subscriber-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

NVD CVE-2025-12388Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Carousel Block vulnerability status badge
<a href="https://laskyr.com/plugins/b-carousel-block"><img src="https://laskyr.com/plugins/b-carousel-block/badge.svg" alt="Carousel Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit