Plugins · b-blocks · data as of 2026-11-04
Is bBlocks safe? Known vulnerabilities and latest version
- Latest version
- 2.1.15
- Last updated
- 2026-11-02
- Active installs
- 600+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
bBlocks enhances the Gutenberg editor with over 90 custom blocks for layout, content, and design, turning it into a powerful WordPress page builder — by bPlugins
What to do
- Update to the latest version (2.1.15). Anything older than 2.1.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get b-blocks --field=version shows what you run; wp plugin update b-blocks updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 1 record(s) do not state which versions are affected.
medium 6.5 CVE-2026-104400 · published 2026-10-05
Stored cross-site scripting (XSS) in bBlocks (2.1.8 and older)
- Affected
- 2.1.8 and older
- Fixed in
- 2.1.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins B Blocks b-blocks allows Stored XSS.This issue affects B Blocks: from n/a through 2.1.8.
high 8.8 CVE-2026-39579 · published 2026-06-15
Privilege escalation in bBlocks (2.0.31 and older)
- Affected
- 2.0.31 and older
- Fixed in
- 2.0.32
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Privilege Escalation in B Blocks <= 2.0.31 versions.
medium 6.5 CVE-2026-32489 · published 2026-03-25
Missing authorization check in bBlocks (not stated by the source)
- Affected
- not stated by the source
- Fixed in
- 2.0.30
- Access needed (per CVSS)
- No login needed
- Range from
- not stated · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in bPlugins B Blocks b-blocks allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects B Blocks: from n/a through < 2.0.30.
medium 6.5 CVE-2025-54708 · published 2025-08-14
Cross-site scripting (XSS) in bBlocks (2.0.5 and older)
- Affected
- 2.0.5 and older
- Fixed in
- 2.0.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins B Blocks b-blocks allows DOM-Based XSS.This issue affects B Blocks: from n/a through <= 2.0.5.
critical 9.8 CVE-2025-8059 · published 2025-08-12
Privilege escalation in bBlocks (2.0.6 and older)
- Affected
- 2.0.6 and older
- Fixed in
- 2.0.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The B Blocks plugin for WordPress is vulnerable to Privilege Escalation due to missing authorization and improper input validation within the rgfr_registration() function in all versions up to, and including, 2.0.6. This makes it possible for unauthenticated attackers to create a new account and assign it the administrator role.
NVD CVE-2025-8059Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 6.5 CVE-2025-32173 · published 2025-04-04
Stored cross-site scripting (XSS) in bBlocks (2.0.0 and older)
- Affected
- 2.0.0 and older
- Fixed in
- 2.0.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins B Blocks b-blocks allows Stored XSS.This issue affects B Blocks: from n/a through <= 2.0.0.
Recent activity
- 2026-11-02 — latest release on wordpress.org (2.1.15).
- 2026-10-05 — Stored cross-site scripting (XSS) disclosed (CVE-2026-104400), fixed in 2.1.9.
- 2026-06-15 — Privilege escalation disclosed (CVE-2026-39579), fixed in 2.0.32.
- 2026-03-25 — Missing authorization check disclosed (CVE-2026-32489), fixed in 2.0.30.
Get an email when bBlocks has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for bBlocks (b-blocks) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by bPlugins (36 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Privilege escalation (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/b-blocks (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/b-blocks"><img src="https://laskyr.com/plugins/b-blocks/badge.svg" alt="bBlocks vulnerability status"></a>