Plugins · ays-slider · data as of 2026-11-04
Is Image Slider by Ays- Responsive Slider and Car… safe? Known vulnerabilities and latest version
- Latest version
- 2.7.3
- Last updated
- 2026-04-15
- Active installs
- 50+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
Ays image slider is a progressive slider plugin, which is a great way to grab your audience's attention with amazing and entertaining slideshows. — by Ays Pro
What to do
- Update to the latest version (2.7.3). Anything older than 2.7.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ays-slider --field=version shows what you run; wp plugin update ays-slider updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-32494 · published 2026-03-25
Cross-site scripting (XSS) in Image Slider by Ays- Responsive Slider and Car… (2.7.1 and older)
- Affected
- 2.7.1 and older
- Fixed in
- 2.7.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- advisory text · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ays Pro Image Slider by Ays ays-slider allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Image Slider by Ays: from n/a through <= 2.7.1.
medium 5.3 CVE-2026-32402 · published 2026-03-13
Missing authorization check in Image Slider by Ays- Responsive Slider and Car… (2.7.1 and older)
- Affected
- 2.7.1 and older
- Fixed in
- 2.7.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Ays Pro Image Slider by Ays ays-slider allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Image Slider by Ays: from n/a through <= 2.7.1.
medium 4.3 CVE-2025-14454 · published 2025-12-13
Cross-site request forgery (CSRF) in Image Slider by Ays- Responsive Slider and Car… (2.7.0 and older)
- Affected
- 2.7.0 and older
- Fixed in
- 2.7.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Image Slider by Ays- Responsive Slider and Carousel plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.7.0. This is due to missing or incorrect nonce validation on the bulk delete functionality. This makes it possible for unauthenticated attackers to delete arbitrary sliders via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2025-14454Wordfence advisoryCode change (fix)Plugin source
high 8.8 CVE-2021-24463 · published 2021-08-02
SQL injection in Image Slider by Ays- Responsive Slider and Car… (older than 2.5.0)
- Affected
- older than 2.5.0
- Fixed in
- 2.5.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- advisory text · score by NVD
Details from the advisory
The get_sliders() function in the Image Slider by Ays- Responsive Slider and Carousel WordPress plugin before 2.5.0 did not use whitelist or validate the orderby parameter before using it in SQL statements passed to the get_results() DB calls, leading to SQL injection issues in the admin dashboard
Recent activity
- 2026-04-15 — latest release on wordpress.org (2.7.3).
- 2026-03-25 — Cross-site scripting (XSS) disclosed (CVE-2026-32494), fixed in 2.7.2.
- 2026-03-13 — Missing authorization check disclosed (CVE-2026-32402), fixed in 2.7.2.
- 2025-12-13 — Cross-site request forgery (CSRF) disclosed (CVE-2025-14454), fixed in 2.7.1.
Get an email when Image Slider by Ays- Responsive Slider and Car… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Image Slider by Ays- Responsive Slider and Car… (ays-slider) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Ays Pro (13 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1) · Cross-site request forgery (CSRF) (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ays-slider (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ays-slider"><img src="https://laskyr.com/plugins/ays-slider/badge.svg" alt="Image Slider by Ays- Responsive Slider and Car… vulnerability status"></a>