Skip to content
Laskyr

Plugins · ays-chatgpt-assistant · data as of 2026-11-04

Is AI ChatBot with ChatGPT and Content Generator… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.8.6)

As of 2026-11-04. 7 issues are on record for older versions; version 2.7.6 or newer fixes all of them that state a fix.

Latest version
2.8.6
Last updated
2026-09-30
Active installs
300+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

AI Writing Assistant, Chatbot, and virtual support all-in-one! Answer customer queries and generate content easily. Works with ChatGPT and Gemini. — by Ays Pro

What to do

  1. Update to the latest version (2.8.6). Anything older than 2.7.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ays-chatgpt-assistant --field=version shows what you run; wp plugin update ays-chatgpt-assistant updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-1336 · published 2026-03-03

Missing authorization check in AI ChatBot with ChatGPT and Content Generator… (2.7.5 and older)

Affected
2.7.5 and older
Fixed in
2.7.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The AI ChatBot with ChatGPT and Content Generator by AYS plugin for WordPress is vulnerable to unauthorized access and modification of data due to missing capability checks on the store_data() and get_chatgpt_api_key() functions in all versions up to, and including, 2.7.5. This makes it possible for unauthenticated attackers to view, modify or delete the plugin's ChatGPT API key. The vulnerability was partially fixed in version 2.7.5 and fully fixed in version 2.7.6

NVD CVE-2026-1336Wordfence advisoryPlugin source

medium 5.3 CVE-2026-25338 · published 2026-02-19

Missing authorization check in AI ChatBot with ChatGPT and Content Generator… (2.7.4 and older)

Affected
2.7.4 and older
Fixed in
2.7.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Ays Pro AI ChatBot with ChatGPT and Content Generator by AYS ays-chatgpt-assistant allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects AI ChatBot with ChatGPT and Content Generator by AYS: from n/a through <= 2.7.4.

NVD CVE-2026-25338Patchstack advisory

medium 5.3 CVE-2025-13381 · published 2025-11-27

Missing authorization check in AI ChatBot with ChatGPT and Content Generator… (2.7.0 and older)

Affected
2.7.0 and older
Fixed in
2.7.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The AI ChatBot with ChatGPT and Content Generator by AYS plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the 'ays_chatgpt_save_wp_media' function in all versions up to, and including, 2.7.0. This makes it possible for unauthenticated attackers to upload media files.

NVD CVE-2025-13381Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-13378 · published 2025-11-27

Server-side request forgery (SSRF) in AI ChatBot with ChatGPT and Content Generator… (2.7.0 and older)

Affected
2.7.0 and older
Fixed in
2.7.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The AI ChatBot with ChatGPT and Content Generator by AYS plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.7.0 via the ays_chatgpt_pinecone_upsert function. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

NVD CVE-2025-13378Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2025-62039 · published 2025-11-06

Information disclosure in AI ChatBot with ChatGPT and Content Generator… (2.6.6 and older)

Affected
2.6.6 and older
Fixed in
2.6.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in Ays Pro AI ChatBot with ChatGPT and Content Generator by AYS ays-chatgpt-assistant allows Retrieve Embedded Sensitive Data.This issue affects AI ChatBot with ChatGPT and Content Generator by AYS: from n/a through <= 2.6.6.

NVD CVE-2025-62039Patchstack advisory

high 7.5 CVE-2024-7714 · published 2024-09-27

Security issue in AI ChatBot with ChatGPT and Content Generator… (older than 2.1.0)

Affected
older than 2.1.0
Fixed in
2.1.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The AI ChatBot with ChatGPT and Content Generator by AYS WordPress plugin before 2.1.0 lacks sufficient access controls allowing an unauthenticated user to disconnect the AI ChatBot with ChatGPT and Content Generator by AYS WordPress plugin before 2.1.0 from OpenAI, thereby disabling the AI ChatBot with ChatGPT and Content Generator by AYS WordPress plugin before 2.1.0. Multiple actions are accessible: 'ays_chatgpt_disconnect', 'ays_chatgpt_connect', and 'ays_chatgpt_save_feedback'

NVD CVE-2024-7714WPScan advisory

high 7.5 CVE-2024-7713 · published 2024-09-27

Security issue in AI ChatBot with ChatGPT and Content Generator… (older than 2.1.0)

Affected
older than 2.1.0
Fixed in
2.1.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The AI ChatBot with ChatGPT and Content Generator by AYS WordPress plugin before 2.1.0 discloses the Open AI API Key, allowing unauthenticated users to obtain it

NVD CVE-2024-7713WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
AI ChatBot with ChatGPT and Content Generator… vulnerability status badge
<a href="https://laskyr.com/plugins/ays-chatgpt-assistant"><img src="https://laskyr.com/plugins/ays-chatgpt-assistant/badge.svg" alt="AI ChatBot with ChatGPT and Content Generator… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit