Skip to content
Laskyr

Plugins · avalon23-products-filter-for-woocommerce · data as of 2026-11-04

Is Avalon23 Products Filter for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.8)

As of 2026-11-04. 1 issue is on record for older versions.

Latest version
1.1.8
Last updated
2026-07-05
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Avalon23 Products Filter – New generation of WooCommerce Products Filters for your ecommerce — by paradigmatools

What to do

  1. Update to the latest version (1.1.8). Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get avalon23-products-filter-for-woocommerce --field=version shows what you run; wp plugin update avalon23-products-filter-for-woocommerce updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-8865 · published 2026-06-24

Stored cross-site scripting (XSS) in Avalon23 Products Filter for WooCommerce (1.1.6 and older)

Affected
1.1.6 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Avalon23 Products Filter for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'avalon23_qr' shortcode in all versions up to, and including, 1.1.6. This is due to insufficient input sanitization and output escaping on user-supplied shortcode attributes (notably 'title' and 'fixed_link') which are concatenated directly into single-quoted HTML attributes by the AVALON23_HELPER::draw_html_item() helper without esc_attr() or any other encoding. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-8865Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Avalon23 Products Filter for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/avalon23-products-filter-for-woocommerce"><img src="https://laskyr.com/plugins/avalon23-products-filter-for-woocommerce/badge.svg" alt="Avalon23 Products Filter for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit