Skip to content
Laskyr

Plugins · avalex · data as of 2026-11-04

Is avalex safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.4)

As of 2026-11-04. 2 issues are on record for older versions; version 3.1.4 or newer fixes all of them that state a fix.

Latest version
3.1.4
Last updated
2026-08-19
Active installs
900+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Automatisch sichere Rechtstexte für Websites, Onlineshops und Dienstleister. Einmal per Plugin installiert, immer aktuell – inklusive Abmahnkostenschu … — by avalex

What to do

  1. Update to the latest version (3.1.4). Anything older than 3.1.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get avalex --field=version shows what you run; wp plugin update avalex updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-25462 · published 2026-03-25

Missing authorization check in avalex (3.1.3 and older)

Affected
3.1.3 and older
Fixed in
3.1.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in avalex avalex avalex allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects avalex: from n/a through <= 3.1.3.

NVD CVE-2026-25462Patchstack advisory

medium 4.8 CVE-2023-25059 · published 2023-04-07

Stored cross-site scripting (XSS) in avalex (3.0.3 and older)

Affected
3.0.3 and older
Fixed in
3.0.4
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in avalex GmbH avalex – Automatically secure legal texts plugin <= 3.0.3 versions.

NVD CVE-2023-25059Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
avalex vulnerability status badge
<a href="https://laskyr.com/plugins/avalex"><img src="https://laskyr.com/plugins/avalex/badge.svg" alt="avalex vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit