Skip to content
Laskyr

Plugins · autoship-cloud · data as of 2026-11-04

Is Autoship Cloud for WooCommerce Subscription Pr… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.18.0)

As of 2026-11-04. 4 issues are on record for older versions; version 2.18.0 or newer fixes all of them that state a fix.

Latest version
2.18.0
Last updated
2026-11-03
Active installs
100+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Use one plugin to automate repeat orders, product subscriptions, and scheduled deliveries for your WooCommerce subscriptions products. — by patternsinthecloud

What to do

  1. Update to the latest version (2.18.0). Anything older than 2.18.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get autoship-cloud --field=version shows what you run; wp plugin update autoship-cloud updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-39762 · published 2026-10-06

Missing authorization check in Autoship Cloud for WooCommerce Subscription Pr… (2.17.1 and older)

Affected
2.17.1 and older
Fixed in
2.18.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Patterns In The Cloud Autoship Cloud for WooCommerce Subscription Products autoship-cloud allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Autoship Cloud for WooCommerce Subscription Products: from n/a through 2.17.1.

NVD CVE-2026-39762Patchstack advisory

medium 4.3 CVE-2026-24527 · published 2026-05-25

Missing authorization check in Autoship Cloud for WooCommerce Subscription Pr… (2.14.0 and older)

Affected
2.14.0 and older
Fixed in
2.14.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Patterns in the cloud Autoship Cloud for WooCommerce Subscription Products allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Autoship Cloud for WooCommerce Subscription Products: from n/a through 2.14.0.

NVD CVE-2026-24527Patchstack advisory

medium 6.5 CVE-2025-26878 · published 2025-02-25

Cross-site scripting (XSS) in Autoship Cloud for WooCommerce Subscription Pr… (2.8.0.1 and older)

Affected
2.8.0.1 and older
Fixed in
2.8.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in patternsinthecloud Autoship Cloud for WooCommerce Subscription Products autoship-cloud allows DOM-Based XSS.This issue affects Autoship Cloud for WooCommerce Subscription Products: from n/a through <= 2.8.0.1.

NVD CVE-2025-26878Patchstack advisory

medium 5.4 CVE-2024-13461 · published 2025-02-21

Stored cross-site scripting (XSS) in Autoship Cloud for WooCommerce Subscription Pr… (2.8.0 and older)

Affected
2.8.0 and older
Fixed in
2.8.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Autoship Cloud for WooCommerce Subscription Products plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'autoship-create-scheduled-order-action' shortcode in all versions up to, and including, 2.8.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-13461Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Autoship Cloud for WooCommerce Subscription Pr… vulnerability status badge
<a href="https://laskyr.com/plugins/autoship-cloud"><img src="https://laskyr.com/plugins/autoship-cloud/badge.svg" alt="Autoship Cloud for WooCommerce Subscription Pr… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit