Skip to content
Laskyr

Plugins · automatic-translations-for-polylang · data as of 2026-11-04

Is AutoPoly safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.4)

As of 2026-11-04. 1 issue is on record for older versions; version 1.6.3 or newer fixes all of them that state a fix.

Latest version
1.6.4
Last updated
2026-10-27
Active installs
5,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

AI Translation For Polylang simplifies your translation process by automatically translating all pages/posts content from one language to another. — by Cool Plugins

What to do

  1. Update to the latest version (1.6.4). Anything older than 1.6.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get automatic-translations-for-polylang --field=version shows what you run; wp plugin update automatic-translations-for-polylang updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-107419 · published 2026-10-09

Missing authorization check in AutoPoly (1.6.2 and older)

Affected
1.6.2 and older
Fixed in
1.6.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Cool Plugins AI Translation for Polylang automatic-translations-for-polylang allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects AI Translation for Polylang: from n/a through 1.6.2.

NVD CVE-2026-107419Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
AutoPoly vulnerability status badge
<a href="https://laskyr.com/plugins/automatic-translations-for-polylang"><img src="https://laskyr.com/plugins/automatic-translations-for-polylang/badge.svg" alt="AutoPoly vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit