Plugins · auto-upload-images · data as of 2026-11-04
Is Auto Upload Images safe? Known vulnerabilities and latest version
- Latest version
- 3.4.1
- Last updated
- 2026-09-20
- Active installs
- 20,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Automatically detect external images in the post content and import images to your site then adding to the media library and replace image urls. — by Ali Irani
What to do
- Update to the latest version (3.4.1). Anything older than 3.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get auto-upload-images --field=version shows what you run; wp plugin update auto-upload-images updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-12106 · published 2026-09-18
Server-side request forgery (SSRF) in Auto Upload Images (3.3.2 and older)
- Affected
- 3.3.2 and older
- Fixed in
- 3.4.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Auto Upload Images plugin for WordPress is vulnerable to Limited Server-Side Request Forgery in all versions up to, and including, 3.3.2 via the downloadImage function. This makes it possible for authenticated attackers, with contributor-level access and above, to make web requests to arbitrary locations originating from the web application. The plugin uses wp_remote_get() rather than wp_safe_remote_get(), and the validate() method only rejects URLs whose host matches the site's own hostname, failing to block requests to private, loopback, or link-local addresses (e.g., 127.0.0.1, 10.0.0.0/8, 169.254.169.254). Attackers can trigger this by embedding a crafted <img> tag with a src attribute pointing to internal network hosts in post content and submitting it for processing.
NVD CVE-2026-12106Wordfence advisoryCode change (fix)Plugin source
medium 4.9 CVE-2025-49985 · published 2025-06-20
Server-side request forgery (SSRF) in Auto Upload Images (3.3.2 and older)
- Affected
- 3.3.2 and older
- Fixed in
- 3.4.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in Ali Irani Auto Upload Images auto-upload-images allows Server Side Request Forgery.This issue affects Auto Upload Images: from n/a through <= 3.3.2.
medium 6.1 CVE-2022-42880 · published 2023-06-13
Cross-site request forgery (CSRF) in Auto Upload Images (3.3 and older)
- Affected
- 3.3 and older
- Fixed in
- 3.3.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Ali Irani Auto Upload Images plugin <= 3.3 versions allows Stored Cross-Site Scripting (XSS).
medium 6.1 CVE-2022-4632 · published 2022-12-21
Cross-site scripting (XSS) in Auto Upload Images (3.0 only, 3.1 only, 3.2 only, 3.3 only)
- Affected
- 3.0 only, 3.1 only, 3.2 only, 3.3 only
- Fixed in
- 3.3.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
A vulnerability has been found in Auto Upload Images up to 3.3.0 and classified as problematic. Affected by this vulnerability is an unknown functionality. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 3.3.1 is able to address this issue. The name of the patch is 895770ee93887ec78429c78ffdfb865bee6f9436. It is recommended to upgrade the affected component. The identifier VDB-216481 was assigned to this vulnerability.
high 8.8 CVE-2022-4633 · published 2022-12-21
Cross-site request forgery (CSRF) in Auto Upload Images (3.0 only, 3.1 only, 3.2 only, 3.3 only)
- Affected
- 3.0 only, 3.1 only, 3.2 only, 3.3 only
- Fixed in
- 3.3.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
A vulnerability was found in Auto Upload Images up to 3.3.0 and classified as problematic. Affected by this issue is some unknown functionality of the file src/setting-page.php of the component Settings Handler. The manipulation leads to cross-site request forgery. The attack may be launched remotely. Upgrading to version 3.3.1 is able to address this issue. The name of the patch is 895770ee93887ec78429c78ffdfb865bee6f9436. It is recommended to upgrade the affected component. VDB-216482 is the identifier assigned to this vulnerability.
Recent activity
- 2026-09-20 — latest release on wordpress.org (3.4.1).
- 2026-09-18 — Server-side request forgery (SSRF) disclosed (CVE-2026-12106), fixed in 3.4.0.
- 2025-06-20 — Server-side request forgery (SSRF) disclosed (CVE-2025-49985), fixed in 3.4.0.
- 2023-06-13 — Cross-site request forgery (CSRF) disclosed (CVE-2022-42880), fixed in 3.3.1.
Get an email when Auto Upload Images has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Auto Upload Images (auto-upload-images) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Server-side request forgery (SSRF) (2) · Cross-site request forgery (CSRF) (2) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/auto-upload-images (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/auto-upload-images"><img src="https://laskyr.com/plugins/auto-upload-images/badge.svg" alt="Auto Upload Images vulnerability status"></a>