Skip to content
Laskyr

Plugins · auto-prune-posts · data as of 2026-11-04

Is Auto Prune Posts safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.1)

As of 2026-11-04. 3 issues are on record for older versions; version 3.1.0 or newer fixes all of them that state a fix.

Latest version
3.1.1
Last updated
2025-11-11
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.8.12

Auto deletes expires (prunes) posts after a certain amount of time. On a per category basis (single category, or all at once. — by ramon fincken

What to do

  1. Update to the latest version (3.1.1). Anything older than 3.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get auto-prune-posts --field=version shows what you run; wp plugin update auto-prune-posts updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-64262 · published 2025-11-13

Cross-site request forgery (CSRF) in Auto Prune Posts (3.0.0 and older)

Affected
3.0.0 and older
Fixed in
3.1.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in ramon fincken Auto Prune Posts auto-prune-posts allows Cross Site Request Forgery.This issue affects Auto Prune Posts: from n/a through <= 3.0.0.

NVD CVE-2025-64262Patchstack advisory

medium 4.8 CVE-2024-10639 · published 2025-05-15

Stored cross-site scripting (XSS) in Auto Prune Posts (older than 3.0.0)

Affected
older than 3.0.0
Fixed in
3.0.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Auto Prune Posts WordPress plugin before 3.0.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

NVD CVE-2024-10639WPScan advisory

high 8.8 CVE-2023-27423 · published 2023-05-18

Cross-site request forgery (CSRF) in Auto Prune Posts (1.8.0 and older)

Affected
1.8.0 and older
Fixed in
2.0.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Ramon Fincken Auto Prune Posts plugin <= 1.8.0 versions.

NVD CVE-2023-27423Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Auto Prune Posts vulnerability status badge
<a href="https://laskyr.com/plugins/auto-prune-posts"><img src="https://laskyr.com/plugins/auto-prune-posts/badge.svg" alt="Auto Prune Posts vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit