Skip to content
Laskyr

Plugins · auto-post-to-social-media-wp-to-social-champ · data as of 2026-11-04

Is Auto Post to Social Media from Social Champ safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.8)

As of 2026-11-04. 1 issue is on record for older versions; version 1.3.6 or newer fixes all of them that state a fix.

Latest version
1.3.8
Last updated
2026-10-20
Active installs
40+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11

It sends WP Pages, Posts or Custom Post Types to your Social Champ (SocialChamp.com) account for immediate or scheduled publishing to social networks. — by Social Champ

What to do

  1. Update to the latest version (1.3.8). Anything older than 1.3.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get auto-post-to-social-media-wp-to-social-champ --field=version shows what you run; wp plugin update auto-post-to-social-media-wp-to-social-champ updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-14846 · published 2026-01-14

Cross-site request forgery (CSRF) in Auto Post to Social Media from Social Champ (1.3.5 and older)

Affected
1.3.5 and older
Fixed in
1.3.6 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SocialChamp with WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.3.5. This is due to missing nonce validation on the wpsc_settings_tab_menu function. This makes it possible for unauthenticated attackers to modify plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-14846Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Auto Post to Social Media from Social Champ vulnerability status badge
<a href="https://laskyr.com/plugins/auto-post-to-social-media-wp-to-social-champ"><img src="https://laskyr.com/plugins/auto-post-to-social-media-wp-to-social-champ/badge.svg" alt="Auto Post to Social Media from Social Champ vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit