Skip to content
Laskyr

Plugins · auto-listings · data as of 2026-11-04

Is Auto Listings safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.4)

As of 2026-11-04. 2 issues are on record for older versions; version 2.7.2 or newer fixes all of them that state a fix.

Latest version
2.7.4
Last updated
2026-07-17
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

List, manage & sell cars easily. Advanced search, vehicle data from 1941, lead capture, gallery, maps. Great for car dealers. — by autolistings

What to do

  1. Update to the latest version (2.7.4). Anything older than 2.7.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get auto-listings --field=version shows what you run; wp plugin update auto-listings updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-69089 · published 2025-12-30

Stored cross-site scripting (XSS) in Auto Listings (2.7.1 and older)

Affected
2.7.1 and older
Fixed in
2.7.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in autolistings Auto Listings auto-listings allows Stored XSS.This issue affects Auto Listings: from n/a through <= 2.7.1.

NVD CVE-2025-69089Patchstack advisory

medium 5.4 CVE-2024-24713 · published 2024-02-10

Stored cross-site scripting (XSS) in Auto Listings (2.6.5 and older)

Affected
2.6.5 and older
Fixed in
2.6.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Auto Listings Auto Listings – Car Listings & Car Dealership Plugin for WordPress allows Stored XSS.This issue affects Auto Listings – Car Listings & Car Dealership Plugin for WordPress: from n/a through 2.6.5.

NVD CVE-2024-24713Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Auto Listings vulnerability status badge
<a href="https://laskyr.com/plugins/auto-listings"><img src="https://laskyr.com/plugins/auto-listings/badge.svg" alt="Auto Listings vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit