Skip to content
Laskyr

Plugins · auto-image-attributes-from-filename-with-bulk-updater · data as of 2026-11-04

Is Auto Image Attributes From Filename With Bulk… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.9.1)

As of 2026-11-04. 1 issue is on record for older versions; version 4.9.1 or newer fixes all of them that state a fix.

Latest version
4.9.1
Last updated
2026-09-01
Active installs
100,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4

Automatically add Image Alt Text, Title, Caption and Description from Filename. Bulk update existing images. Great for Image SEO and Accessibility. — by Arun Basil Lal

What to do

  1. Update to the latest version (4.9.1). Anything older than 4.9.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get auto-image-attributes-from-filename-with-bulk-updater --field=version shows what you run; wp plugin update auto-image-attributes-from-filename-with-bulk-updater updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-3722 · published 2026-06-02

Stored cross-site scripting (XSS) in Auto Image Attributes From Filename With Bulk… (4.9 and older)

Affected
4.9 and older
Fixed in
4.9.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Auto Image Attributes From Filename With Bulk Updater (Add Alt Text, Image Title For Image SEO) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the attachment metadata in all versions up to, and including, 4.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-3722Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Auto Image Attributes From Filename With Bulk… vulnerability status badge
<a href="https://laskyr.com/plugins/auto-image-attributes-from-filename-with-bulk-updater"><img src="https://laskyr.com/plugins/auto-image-attributes-from-filename-with-bulk-updater/badge.svg" alt="Auto Image Attributes From Filename With Bulk… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit