Skip to content
Laskyr

Plugins · authorsy · data as of 2026-11-04

Is Authorsy safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.8)

As of 2026-11-04. 2 issues are on record for older versions; version 1.0.7 or newer fixes all of them that state a fix.

Latest version
1.0.8
Last updated
2026-06-30
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Authorsy is a powerful WordPress author box plugin. Add customizable author profiles, multiple authors, guest authors, bios, social links, and post ra … — by Apselo

What to do

  1. Update to the latest version (1.0.8). Anything older than 1.0.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get authorsy --field=version shows what you run; wp plugin update authorsy updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-24950 · published 2026-02-20

Missing authorization check in Authorsy (1.0.6 and older)

Affected
1.0.6 and older
Fixed in
1.0.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in themeplugs Authorsy authorsy allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Authorsy: from n/a through <= 1.0.6.

NVD CVE-2026-24950Patchstack advisory

medium 6.5 CVE-2025-27006 · published 2025-09-26

Stored cross-site scripting (XSS) in Authorsy (1.0.5 and older)

Affected
1.0.5 and older
Fixed in
1.0.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in themeplugs Authorsy authorsy allows Stored XSS.This issue affects Authorsy: from n/a through <= 1.0.5.

NVD CVE-2025-27006Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Authorsy vulnerability status badge
<a href="https://laskyr.com/plugins/authorsy"><img src="https://laskyr.com/plugins/authorsy/badge.svg" alt="Authorsy vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit