Skip to content
Laskyr

Plugins · authorizer · data as of 2026-11-04

Is Authorizer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.16.0)

As of 2026-11-04. 2 issues are on record for older versions; version 3.16.0 or newer fixes all of them that state a fix.

Latest version
3.16.0
Last updated
2026-09-21
Active installs
7,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

Authorizer limits login attempts, restricts access to specific users, and authenticates against external sources (OAuth2, Google, LDAP, or CAS). — by Paul Ryan

What to do

  1. Update to the latest version (3.16.0). Anything older than 3.16.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get authorizer --field=version shows what you run; wp plugin update authorizer updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-103752 · published 2026-10-01

Privilege escalation in Authorizer (3.15.3 and older)

Affected
3.15.3 and older
Fixed in
3.16.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Privilege Escalation in Authorizer <= 3.15.3 versions.

NVD CVE-2026-103752Patchstack advisory

critical 9.8 CVE-2026-81294 · published 2026-09-02

Privilege escalation in Authorizer (3.15.1 and older)

Affected
3.15.1 and older
Fixed in
3.15.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Privilege Escalation in Authorizer <= 3.15.1 versions.

NVD CVE-2026-81294Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Authorizer vulnerability status badge
<a href="https://laskyr.com/plugins/authorizer"><img src="https://laskyr.com/plugins/authorizer/badge.svg" alt="Authorizer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit