Skip to content
Laskyr

Plugins · audio-and-video-player · data as of 2026-11-04

Is CP Media Player safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.4)

As of 2026-11-04. 3 issues are on record for older versions; version 1.3.4 or newer fixes all of them that state a fix.

Latest version
1.3.4
Last updated
2026-10-03
Active installs
3,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

CP Media Player adds audio and video players with playlists, downloads, subtitles, multiple formats, and support for desktop and mobile browsers. — by codepeople

What to do

  1. Update to the latest version (1.3.4). Anything older than 1.3.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get audio-and-video-player --field=version shows what you run; wp plugin update audio-and-video-player updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

low 2.7 CVE-2026-104678 · published 2026-10-07

Missing authorization check in CP Media Player (older than 1.3.4)

Affected
older than 1.3.4
Fixed in
1.3.4
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The CP Media Player WordPress plugin before 1.3.4 does not perform a capability check on its settings-page handler, allowing users with only Contributor-level access to create, modify, duplicate and delete the site-wide media player configurations and change a CP Media Player WordPress plugin before 1.3.4 option that should require administrator access.

NVD CVE-2026-104678WPScan advisory

high 7.1 CVE-2026-78281 · published 2026-08-27

Cross-site scripting (XSS) in CP Media Player (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in CP Media Player <= 1.3.0 versions.

NVD CVE-2026-78281Patchstack advisory

medium 5.4 CVE-2024-31941 · published 2024-04-15

Cross-site request forgery (CSRF) in CP Media Player (1.1.3 and older)

Affected
1.1.3 and older
Fixed in
1.2.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in CodePeople CP Media Player.This issue affects CP Media Player: from n/a through 1.1.3.

NVD CVE-2024-31941Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
CP Media Player vulnerability status badge
<a href="https://laskyr.com/plugins/audio-and-video-player"><img src="https://laskyr.com/plugins/audio-and-video-player/badge.svg" alt="CP Media Player vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit