Plugins · attendance-manager · data as of 2026-11-04
Is Attendance Manager safe? Known vulnerabilities and latest version
- Latest version
- 0.6.5
- Last updated
- 2026-06-17
- Active installs
- 700+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.0+
Each user can do attendance management by themselves. — by tnomi
What to do
- Update to the latest version (0.6.5). Anything older than 0.6.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get attendance-manager --field=version shows what you run; wp plugin update attendance-manager updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.6 CVE-2026-52712 · published 2026-06-16
SQL injection in Attendance Manager (0.6.2 and older)
- Affected
- 0.6.2 and older
- Fixed in
- 0.6.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber SQL Injection in Attendance Manager <= 0.6.2 versions.
medium 5.4 CVE-2026-3781 · published 2026-04-08
SQL injection in Attendance Manager (0.6.2 and older)
- Affected
- 0.6.2 and older
- Fixed in
- 0.6.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Attendance Manager plugin for WordPress is vulnerable to SQL Injection via the 'attmgr_off' parameter in all versions up to, and including, 0.6.2. This is due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
medium 6.5 CVE-2025-39515 · published 2025-04-16
Stored cross-site scripting (XSS) in Attendance Manager (0.6.2 and older)
- Affected
- 0.6.2 and older
- Fixed in
- 0.6.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in tnomi Attendance Manager attendance-manager allows Stored XSS.This issue affects Attendance Manager: from n/a through <= 0.6.2.
medium 6.1 CVE-2019-5970 · published 2019-07-05
Cross-site scripting (XSS) in Attendance Manager (0.5.6 and older)
- Affected
- 0.5.6 and older
- Fixed in
- 0.5.7 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
Cross-site scripting vulnerability in Attendance Manager 0.5.6 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
high 8.8 CVE-2019-5971 · published 2019-07-05
Cross-site request forgery (CSRF) in Attendance Manager (0.5.6 and older)
- Affected
- 0.5.6 and older
- Fixed in
- 0.5.7 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
Cross-site request forgery (CSRF) vulnerability in Attendance Manager 0.5.6 and earlier allows remote attackers to hijack the authentication of administrators via unspecified vectors.
Recent activity
- 2026-06-17 — latest release on wordpress.org (0.6.5).
- 2026-06-16 — SQL injection disclosed (CVE-2026-52712), fixed in 0.6.3.
- 2026-04-08 — SQL injection disclosed (CVE-2026-3781), fixed in 0.6.3.
- 2025-04-16 — Stored cross-site scripting (XSS) disclosed (CVE-2025-39515), fixed in 0.6.3.
Get an email when Attendance Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Attendance Manager (attendance-manager) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (2) · Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/attendance-manager (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/attendance-manager"><img src="https://laskyr.com/plugins/attendance-manager/badge.svg" alt="Attendance Manager vulnerability status"></a>